summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-03-30 23:48:13 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-31 14:16:13 +0200
commitc000352c27f511dfb5569bef09f9b774d6100117 (patch)
treeca8f6b37cfd0506db1c4440ab1f2bf45fedb031a /gnu/packages/gnome.scm
parent3b57a9cac8962068a3abad1aa09477e9a433460e (diff)
downloadguix-c000352c27f511dfb5569bef09f9b774d6100117.tar.gz
gnu: Replace all uses of atk by at-spi2-core.
* gnu/packages/animation.scm (gnash)
* gnu/packages/chromium.scm (ungoogled-chromium)
* gnu/packages/crates-gtk.scm (rust-atk-sys-0.14,
rust-atk-sys-0.10, rust-atk-0.14, rust-gtk-0.14)
* gnu/packages/gimp.scm (gimp)
* gnu/packages/gnome.scm (evince, glade3, clutter, totem, rhythmbox, mutter, ghex):
* gnu/packages/graphviz.scm (xdot)
* gnu/packages/gtk.scm (gtk+-2, gtk+, guile-gnome, atkmm)
* gnu/packages/mate.scm (mate-applets, atril, mate-control-center, mate-calc,
mate-utils, eom, pluma)
* gnu/packages/messaging.scm (dino)
* gnu/packages/qt.scm (qtwebengine-5)
* gnu/packages/rust-apps.scm (alfis)
* gnu/packages/vim.scm (vim-full)
* gnu/packages/vnc.scm (remmina)
* gnu/packages/web.scm (castor): Replace atk by at-spi2-core.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e2ee396819..e81882b181 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2704,7 +2704,7 @@ forgotten when the session ends.")
            libgnome-keyring
            adwaita-icon-theme
            gdk-pixbuf
-           atk
+           at-spi2-core
            pango
            gtk+
            glib
@@ -3299,7 +3299,7 @@ API add-ons to make GTK+ widgets OpenGL-capable.")
           '())
       (list gtk+ libxml2)))
     (native-inputs
-     (list atk                          ;for tests
+     (list at-spi2-core                          ;for tests
            docbook-xml-4.2
            docbook-xsl
            gettext-minimal
@@ -6357,7 +6357,7 @@ without stepping on each others toes.")
            libxslt
            pkg-config))
     (propagated-inputs
-     (list atk
+     (list at-spi2-core
            cairo
            cogl
            glib
@@ -6744,7 +6744,7 @@ discovery protocols.")
     (inputs
      (list gtk+
            gdk-pixbuf
-           atk
+           at-spi2-core
            cairo
            dbus-glib
            xorgproto
@@ -6866,7 +6866,7 @@ which can read a large number of file formats.")
      ;;clutter-gtk
      ;;clutter-gst
      (list adwaita-icon-theme
-           atk
+           at-spi2-core
            bash-minimal
            brasero
            json-glib
@@ -8021,7 +8021,7 @@ to display dialog boxes from the commandline and shell scripts.")
      (list gsettings-desktop-schemas-next ;required by libmutter.pc
            gtk+                           ;required by libmutter.pc
            ;; mutter-clutter-1.0.pc and mutter-cogl-1.0.pc refer to these:
-           atk
+           at-spi2-core
            cairo
            eudev
            gdk-pixbuf
@@ -11646,7 +11646,7 @@ micro-pauses and rest breaks, and restricts you to your daily limit.")
            pkg-config
            yelp-tools))
     (inputs
-     (list atk
+     (list at-spi2-core
            gtk))
     (synopsis "GNOME hexadecimal editor")
     (description "The GHex program can view and edit files in two ways: