summary refs log tree commit diff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-01-09 23:01:59 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-05-31 22:12:12 -0400
commitca3adf26072c759b198042ced866efc423dd4b97 (patch)
treeccbe61e3f04e46f2024ffa5a8a30325f5051111a /gnu/packages/gnome.scm
parent88e61bd4a4e14061f194b4e883ee6af8850ecb1f (diff)
downloadguix-ca3adf26072c759b198042ced866efc423dd4b97.tar.gz
gnu: Add gdl-minimal.
* gnu/packages/gnome.scm (gdl-minimal): New variable.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c5e0959b23..da69f1bdeb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1548,6 +1548,27 @@ GNOME Desktop.")
     (description "This library provides docking features for gtk+.")
     (license license:lgpl2.1+)))
 
+;;; A minimal variant used to break a cycle with Inkscape.
+(define-public gdl-minimal
+  (package
+    (inherit gdl)
+    (name "gdl-minimal")
+    (arguments
+     (substitute-keyword-arguments (package-arguments gdl)
+       ((#:phases phases)
+        `(modify-phases ,phases
+           (add-after 'unpack 'disable-doc-generation
+             ;; XXX: There is no easy way to disable generating the
+             ;; documentation.
+             (lambda _
+               (substitute* "configure.in"
+                 (("GTK_DOC_CHECK.*") "")
+                 (("docs/.*") ""))
+               (substitute* "Makefile.am"
+                 (("gdl docs po") "gdl po"))
+               #t))))))
+    (native-inputs (alist-delete "gtk-doc" (package-native-inputs gdl)))))
+
 (define-public libgnome-keyring
   (package
     (name "libgnome-keyring")