summary refs log tree commit diff
path: root/gnu/packages/gnucash.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-03-26 10:22:15 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-26 10:26:02 +0100
commite6301fb76d0a8d931ece2e18d197e3c2cc53fc6c (patch)
tree481d8ff64542c7bc1498c208e2faa01464ba0b27 /gnu/packages/gnucash.scm
parent6c177f6140cba250ad68c5a83c312f395b6e48b4 (diff)
downloadguix-e6301fb76d0a8d931ece2e18d197e3c2cc53fc6c.tar.gz
packages: Adjust to new calling convention for "thunked" fields.
Fixes <https://bugs.gnu.org/34995>.

This is a followup to abd4d6b33dba4de228e90ad15a8efb456fcf7b6e.

* guix/packages.scm (package->bag): Adjust calls to INPUTS,
PROPAGATED-INPUTS, NATIVE-INPUTS, and ARGS, passing them SELF as an
argument.
* gnu/packages/gnucash.scm (gnucash)[arguments]: Use (package-inputs
this-record) intead of (inputs).
* gnu/packages/version-control.scm (git)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages/gnucash.scm')
-rw-r--r--gnu/packages/gnucash.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index 2207dd3fae..84b244cdd9 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -27,6 +27,7 @@
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system cmake)
+  #:use-module ((guix records) #:select (this-record))
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
@@ -165,14 +166,14 @@
                                         ,@(transitive-input-references
                                            'inputs
                                            (map (lambda (l)
-                                                  (assoc l (inputs)))
+                                                  (assoc l (package-inputs this-record)))
                                                 '("perl-finance-quote"
                                                   "perl-date-manip"))))
                                        (list
                                         ,@(transitive-input-references
                                            'inputs
                                            (map (lambda (l)
-                                                  (assoc l (inputs)))
+                                                  (assoc l (package-inputs this-record)))
                                                 '("perl-finance-quote")))))))))
                        '("gnucash"
                          "gnc-fq-check"