summary refs log tree commit diff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-10 18:47:02 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-10 18:47:02 +0100
commit96ab233df7eefd4c868a9e9628b834458e9f18d3 (patch)
treeee28a833f9126245d394bf5b2674c7ced3a3bba8 /gnu/packages/gnunet.scm
parentb4d7689f9255b93b9ea02e01dc490f1416f77782 (diff)
parenta4de1a651e75c9b9d5e6bdb993f5bd5f74875d49 (diff)
downloadguix-96ab233df7eefd4c868a9e9628b834458e9f18d3.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 685cbdedec..461180161e 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -148,14 +148,14 @@ tool to extract metadata from a file and print the results.")
 (define-public libmicrohttpd
   (package
    (name "libmicrohttpd")
-   (version "0.9.62")
+   (version "0.9.63")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/libmicrohttpd/libmicrohttpd-"
                                 version ".tar.gz"))
             (sha256
              (base32
-              "0jfvi1fb4im3a3m8qishbmzx3zch993c0mhvl2k92l1zf1yhjgmx"))))
+              "173lj66crwvhzwp1r812sc5h1hda7g6lb9l1y5zf7w3pw4dnzhrp"))))
    (build-system gnu-build-system)
    (inputs
     `(("curl" ,curl)
@@ -163,18 +163,6 @@ tool to extract metadata from a file and print the results.")
       ("libgcrypt" ,libgcrypt)
       ("openssl" ,openssl)
       ("zlib" ,zlib)))
-   (arguments
-    `(#:parallel-tests? #f
-      #:phases (modify-phases %standard-phases
-                 (add-before 'check 'add-missing-LDFLAGS
-                   (lambda _
-                     ;; The two test_upgrade* programs depend on GnuTLS
-                     ;; directly but lack -lgnutls; add it.
-                     (substitute* "src/microhttpd/Makefile"
-                       (("^test_upgrade(.*)LDFLAGS = (.*)$" _ first rest)
-                        (string-append "test_upgrade" first
-                                       "LDFLAGS = -lgnutls " rest)))
-                     #t)))))
    (synopsis "C library implementing an HTTP 1.1 server")
    (description
     "GNU libmicrohttpd is a small, embeddable HTTP server implemented as a