summary refs log tree commit diff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-03-09 20:36:21 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-03-31 21:25:50 -0400
commitf0698ffb5279ed7747d49b48ef3f8a507916daa5 (patch)
treedbf02128af6bfc4d12aa209ae95a53c75be62361 /gnu/packages/gnunet.scm
parentb4c2c984d71fdb1166fe292ba8739e0cec0dd712 (diff)
downloadguix-f0698ffb5279ed7747d49b48ef3f8a507916daa5.tar.gz
gnu: gnurl: Update to 7.72.0.
* gnu/packages/gnunet.scm (gnurl): Update to 7.72.0.
[arguments] <test-target>: Specify 'test-nonflaky' target.
<configure-flags>: Use gexps.
<phases>: Likewise.  Add patch-paths phase.

Change-Id: Idcb6a6f2115176c9aa6074b916313e9640416033
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm120
1 files changed, 60 insertions, 60 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index f58ecc1404..0bf524c148 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -190,70 +190,70 @@ authentication and support for SSL3 and TLS.")
 
 (define-public gnurl
   (package
-   (name "gnurl")
-   (version "7.70.0")
-   (source (origin
-            (method url-fetch)
-            (uri (string-append "mirror://gnu/gnunet/gnurl-" version ".tar.gz"))
-            (sha256
-             (base32
-              "0px9la8v4bj1dzxb95fx3yxk0rcjqjrxpj733ga27cza45wwzkqa"))))
-   (build-system gnu-build-system)
-   (outputs '("out"
-              "doc"))                             ; 1.8 MiB of man3 pages
-   (inputs `(("gnutls" ,gnutls/dane)
-             ("libidn2" ,libidn2)
-             ("zlib" ,zlib)))
-   (native-inputs
-    (list libtool perl pkg-config python))
-   (arguments
-    `(#:configure-flags
+    (name "gnurl")
+    (version "7.72.0")
+    ;; Fetch from git, as the tarball causes the build to fail with "No rule
+    ;; to make target 'convsrctest.pl', needed by 'all-am'." (see
+    ;; https://bugs.gnunet.org/view.php?id=8684).
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.taler.net/gnurl.git")
+                    (commit (string-append name "-" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0b3jqxlarkiphf71i50vnvsmr8gh38ishrxqqbq77m0hjwyx4kv1"))))
+    (build-system gnu-build-system)
+    (outputs '("out"
+               "doc"))                  ; 1.8 MiB of man3 pages
+    (arguments
+     (list
+      #:test-target "test-nonflaky"     ;do not run flaky tests
+      #:configure-flags
       ;; All of these produce errors during configure.
-      (list "--disable-ftp"
-            "--disable-file"
-            "--disable-ldap"
-            "--disable-rtsp"
-            "--disable-dict"
-            "--disable-telnet"
-            "--disable-tftp"
-            "--disable-pop3"
-            "--disable-imap"
-            "--disable-smb"
-            "--disable-smtp"
-            "--disable-gopher"
-            "--without-ssl"
-            "--without-libpsl"
-            "--without-librtmp"
-            "--disable-ntlm-wb")
+      #~(list "--disable-ftp"
+              "--disable-file"
+              "--disable-ldap"
+              "--disable-rtsp"
+              "--disable-dict"
+              "--disable-telnet"
+              "--disable-tftp"
+              "--disable-pop3"
+              "--disable-imap"
+              "--disable-smb"
+              "--disable-smtp"
+              "--disable-gopher"
+              "--without-ssl"
+              "--without-libpsl"
+              "--without-librtmp"
+              "--disable-ntlm-wb")
       #:phases
-      (modify-phases %standard-phases
-        (add-after 'install 'move-man3-pages
-          (lambda* (#:key outputs #:allow-other-keys)
-            ;; Move section 3 man pages to "doc".
-            (let ((out (assoc-ref outputs "out"))
-                  (doc (assoc-ref outputs "doc")))
-              (mkdir-p (string-append doc "/share/man"))
-              (rename-file (string-append out "/share/man/man3")
-                           (string-append doc "/share/man/man3"))
-              #t)))
-        ;; We have to patch runtests.pl in tests/ directory
-        (replace 'check
-          (lambda _
-            (substitute* "tests/runtests.pl"
-              (("/bin/sh") (which "sh")))
-
-            ;; Make test output more verbose.
-            (invoke "make" "-C" "tests" "test"))))))
-   (synopsis "Microfork of cURL with support for the HTTP/HTTPS/GnuTLS subset of cURL")
-   (description
-    "Gnurl is a microfork of cURL, a command line tool for transferring data
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-paths
+            (lambda _
+              (substitute* "tests/runtests.pl.in"
+                (("/bin/sh")
+                 (which "sh")))))
+          (add-after 'install 'move-man3-pages
+            (lambda _
+              ;; Move section 3 man pages to "doc".
+              (mkdir-p (string-append #$output:doc "/share/man"))
+              (rename-file (string-append #$output "/share/man/man3")
+                           (string-append #$output:doc "/share/man/man3")))))))
+    (native-inputs (list autoconf automake libtool perl pkg-config python))
+    (inputs (list gnutls/dane libidn2 zlib))
+    (synopsis
+     "Microfork of cURL with support for the HTTP/HTTPS/GnuTLS subset of cURL")
+    (description
+     "Gnurl is a microfork of cURL, a command line tool for transferring data
 with URL syntax.  While cURL supports many crypto backends, libgnurl only
 supports HTTP, HTTPS and GnuTLS.")
-   (license (license:non-copyleft "file://COPYING"
-                                  "See COPYING in the distribution."))
-   (properties '((ftp-server . "ftp.gnu.org")
-                 (ftp-directory . "/gnunet")))
-   (home-page "https://gnunet.org/en/gnurl.html")))
+    (license (license:non-copyleft "file://COPYING"
+                                   "See COPYING in the distribution."))
+    (properties '((ftp-server . "ftp.gnu.org")
+                  (ftp-directory . "/gnunet")))
+    (home-page "https://gnunet.org/en/gnurl.html")))
 
 (define-public gnunet
   (package