summary refs log tree commit diff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-08-26 00:41:07 +0200
committerLudovic Courtès <ludo@gnu.org>2015-08-26 00:43:37 +0200
commit14e2e44d44e0be0b010ca4f71a999ed631808da4 (patch)
tree70e85873e5d927c112e0c9e79e9642f63590b4ac /gnu/packages/gnupg.scm
parentfe32241ad5394c12fc70a31de005ec1b563bbb4e (diff)
downloadguix-14e2e44d44e0be0b010ca4f71a999ed631808da4.tar.gz
gnu: pius: Adjust to the new libpius.
Prior to this commit the libpius modules would not be found and the default
GnuPG file name would be /usr/bin/gpg.

* gnu/packages/gnupg.scm (pius)[inputs]: Remove PYTHON-2.
  [build-system]: Switch to PYTHON-BUILD-SYSTEM.
  [arguments]: Add #:python.  Change to add a single phase,
  'set-gpg-file-name'.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm35
1 files changed, 13 insertions, 22 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 8404b01479..b66eec3843 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -36,7 +36,8 @@
   #:use-module (gnu packages tls)
   #:use-module (guix packages)
   #:use-module (guix download)
-  #:use-module (guix build-system gnu))
+  #:use-module (guix build-system gnu)
+  #:use-module (guix build-system python))
 
 (define-public libgpg-error
   (package
@@ -335,31 +336,21 @@ and every application benefits from this.")
                                 version ".tar.bz2"))
             (sha256 (base32
                      "0ry3kc3x1qjmvb581ja2z2v32r1rl1g8rhfj7iqvs8nzq4ca512i"))))
-   (build-system gnu-build-system)
-   (inputs `(("perl" ,perl)
-             ("python" ,python-2)          ;uses the Python 2 'print' syntax
+   (build-system python-build-system)
+   (inputs `(("perl" ,perl)                ;for 'pius-party-worksheet'
              ("gpg" ,gnupg-2.0)))          ;2.1 fails to talk to gpg-agent 2.0
    (arguments
     `(#:tests? #f
+      #:python ,python-2                     ;uses the Python 2 'print' syntax
       #:phases
-       (alist-delete
-        'configure
-       (alist-delete
-        'build
-       (alist-replace
-        'install
-        (lambda* (#:key inputs outputs #:allow-other-keys)
-          (let* ((out (assoc-ref outputs "out"))
-                 (gpg (string-append (assoc-ref inputs "gpg")
-                                     "/bin/gpg2")))
-            (mkdir out)
-            (mkdir (string-append out "/bin"))
-            (for-each (lambda (file)
-                        (substitute* file
-                          (("/usr/bin/gpg") gpg))
-                        (copy-file file (string-append out "/bin/" file)))
-                      '("pius" "pius-keyring-mgr" "pius-party-worksheet"))))
-       %standard-phases)))))
+      (modify-phases %standard-phases
+        (add-before
+         'build 'set-gpg-file-name
+         (lambda* (#:key inputs outputs #:allow-other-keys)
+           (let* ((gpg (string-append (assoc-ref inputs "gpg")
+                                      "/bin/gpg2")))
+             (substitute* "libpius/constants.py"
+               (("/usr/bin/gpg") gpg))))))))
    (synopsis "Programs to simplify GnuPG key signing")
    (description
     "Pius (PGP Individual UID Signer) helps attendees of PGP keysigning