summary refs log tree commit diff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-08-20 08:37:22 +0000
committerLeo Famulari <leo@famulari.name>2016-08-21 18:08:12 -0400
commitdd582f4ae55ee341d9a11c34f5e20e4b287ffe2b (patch)
treee6c212de6a5f5b0942e8f8dc1cde5ae44184dcdb /gnu/packages/gnupg.scm
parentf041616da1413a9e5fdc8e54a90890d70be25572 (diff)
downloadguix-dd582f4ae55ee341d9a11c34f5e20e4b287ffe2b.tar.gz
gnu: gnupg: Fix test failures.
* gnu/packages/gnupg.scm (gnupg)[arguments]: Set $HOME before 'check' phase.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 27db5c3d76..52a9fc5366 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -247,7 +247,13 @@ compatible to GNU Pth.")
           (lambda _
             (substitute* (find-files "tests" ".\\.scm$")
               (("/usr/bin/env gpgscm")
-               (string-append (getcwd) "/tests/gpgscm/gpgscm"))))))))
+               (string-append (getcwd) "/tests/gpgscm/gpgscm")))))
+        (add-before 'check 'set-home
+          ;; Some tests require write access to $HOME, otherwise leading to
+          ;; 'failed to create directory /homeless-shelter/.asy' error.
+          (lambda _
+            (setenv "HOME" "/tmp")
+            #t)))))
     (home-page "https://gnupg.org/")
     (synopsis "GNU Privacy Guard")
     (description