summary refs log tree commit diff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-12-20 03:20:09 -0500
committerLeo Famulari <leo@famulari.name>2017-12-20 15:13:22 -0500
commite6f63412c9abe6a3b4ddf0ce39735d1e2a65491d (patch)
treece82148a9527eb3ff652d5035bba44597de3bb0b /gnu/packages/gnupg.scm
parent5965b08307a61fa5472309ac4f7df86bc6037364 (diff)
downloadguix-e6f63412c9abe6a3b4ddf0ce39735d1e2a65491d.tar.gz
gnu: python-pygpgme: Use GnuPG 1 for the test suite.
* gnu/packages/gnupg.scm (python-pygpgme, python2-pygpgme)[inputs]: Use gnupg-1
and make it a native-input.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 4d93044195..a9b097b212 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -492,9 +492,10 @@ distributed separately.")
            (lambda _
              (zero? (system* "make" "check")))))))
     (build-system python-build-system)
+    (native-inputs
+     `(("gnupg" ,gnupg-1)))
     (inputs
-     `(("gnupg" ,gnupg-2.0)
-       ("gpgme" ,gpgme)))
+     `(("gpgme" ,gpgme)))
     (home-page "https://launchpad.net/pygpgme")
     (synopsis "Python module for working with OpenPGP messages")
     (description