summary refs log tree commit diff
path: root/gnu/packages/gnustep.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-15 23:28:51 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-16 11:11:40 +0100
commitbfe83d568c75434501a471dbaed273d213320470 (patch)
tree1e438a1522007d3b22642aa68e74f487447787c0 /gnu/packages/gnustep.scm
parent9a0a4a95f02f0ad2e3589af398421445f7e8a949 (diff)
downloadguix-bfe83d568c75434501a471dbaed273d213320470.tar.gz
gnu: gnustep: Update phase style.
* gnu/packages/gnustep.scm (windowmaker)[arguments]: Don't use %OUTPUT.
End phases with #t.
(wmbattery, wmclock)[arguments]: Substitute INVOKE for SYSTEM*.  End
phases with #t.
Diffstat (limited to 'gnu/packages/gnustep.scm')
-rw-r--r--gnu/packages/gnustep.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/gnustep.scm b/gnu/packages/gnustep.scm
index dd49386764..05ad9b745a 100644
--- a/gnu/packages/gnustep.scm
+++ b/gnu/packages/gnustep.scm
@@ -102,7 +102,8 @@ to easily create cross-compiled binaries.")
                ;; The path to wmsetbg in Guix requires 67 extra characters.
                (substitute* "src/defaults.c"
                  (("len = strlen\\(text\\) \\+ 40;")
-                  (string-append "len = strlen(text) + 107;"))))))
+                  (string-append "len = strlen(text) + 107;")))
+               #t)))
          (add-after 'install 'install-xsession
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
@@ -120,7 +121,7 @@ to easily create cross-compiled binaries.")
                           (string-map (match-lambda
                                         (#\newline #\space)
                                         (chr chr))
-                                      ,synopsis) %output))))
+                                      ,synopsis) out))))
              #t))
          (add-after 'install-xsession 'wrap
             (lambda* (#:key outputs #:allow-other-keys)
@@ -129,7 +130,8 @@ to easily create cross-compiled binaries.")
                 ;; In turn, 'wmaker.inst' wants to invoke 'wmmenugen'
                 ;; etc., so make sure everything is in $PATH.
                 (wrap-program (string-append bin "/wmaker.inst")
-                  `("PATH" ":" prefix (,bin)))))))))
+                  `("PATH" ":" prefix (,bin)))
+                #t))))))
     (inputs
      `(("libxmu" ,libxmu)
        ("libxft" ,libxft)
@@ -170,7 +172,9 @@ interface.  It is fast, feature rich, easy to configure, and easy to use.")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'autoconf
-           (lambda _ (zero? (system* "autoreconf" "-vfi")))))))
+           (lambda _
+             (invoke "autoreconf" "-vfi")
+             #t)))))
     (inputs
      `(("glib" ,glib)
        ("libx11" ,libx11)
@@ -262,7 +266,9 @@ on.")
      `(#:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'autoconf
-           (lambda _ (zero? (system* "autoreconf" "-vfi")))))))
+           (lambda _
+             (invoke "autoreconf" "-vfi")
+             #t)))))
     ;; wmclock requires autoreconf to generate its configure script.
     (inputs
      `(("libx11" ,libx11)