summary refs log tree commit diff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-10-01 16:21:05 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 11:00:02 +0000
commit5d8515b3373be49bfccd3557bf621e3b64ba2cd0 (patch)
treedb3f6f5247c3f92b6eed712eb587879601b18278 /gnu/packages/gnuzilla.scm
parent385ba2f369e8fd65e5387185c36127cef7a78488 (diff)
downloadguix-5d8515b3373be49bfccd3557bf621e3b64ba2cd0.tar.gz
gnu: mozjs: Use mozilla-build-system.
Due to the use of 'inherit', all versions of mozjs are adjusted.

* gnu/packages/gnuzilla.scm
  (mozjs)[build-system]: Adjust it.
  (mozjs)[arguments]<#:configure-flags>: Remove now superfluous --target and
  --host.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 5dd90e4e20..9647bb7db5 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -49,6 +49,7 @@
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system cargo)
   #:use-module (guix build-system trivial)
+  #:use-module (guix build-system mozilla)
   #:use-module (gnu packages admin)
   #:use-module (gnu packages audio)
   #:use-module (gnu packages autotools)
@@ -108,7 +109,7 @@
                  (substitute* '("js/src/config/milestone.pl")
                    (("defined\\(@TEMPLATE_FILE)") "@TEMPLATE_FILE"))
                  #t))))
-    (build-system gnu-build-system)
+    (build-system mozilla-build-system)
     (native-inputs
      `(("perl" ,perl)
        ("pkg-config" ,pkg-config)
@@ -390,15 +391,7 @@ in C/C++.")
             ;; This is important because without it gjs will segfault during the
             ;; configure phase.  With jemalloc only the standalone mozjs console
             ;; will work.
-            "--disable-jemalloc"
-            ;; Mozilla deviates from Autotools conventions due to historical
-            ;; reasons.
-            #$@(if (%current-target-system)
-                   #~(#$(string-append
-                         "--host="
-                         (nix-system->gnu-triplet (%current-system)))
-                      #$(string-append "--target=" (%current-target-system)))
-                   #~())))
+            "--disable-jemalloc"))
        #:phases
        (modify-phases %standard-phases
          ;; Make sure pkg-config will be found.