summary refs log tree commit diff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2019-10-26 22:17:05 -0400
committerMark H Weaver <mhw@netris.org>2019-10-29 01:22:52 -0400
commita06193603b7e7922439fc5a9d616b7ef872b8b03 (patch)
tree857e11491324139734598037cc0a3774d694a751 /gnu/packages/gnuzilla.scm
parentce23c5ffd2cbb123943c424f09d1442f557a14ed (diff)
downloadguix-a06193603b7e7922439fc5a9d616b7ef872b8b03.tar.gz
gnu: icecat: Include generally-useful fixes in the source tarball.
This commit moves some important fixes into a patch applied to the upstream
gnuzilla git repository, whereas previously they were applied in such a way
that only benefitted Guix users.

* gnu/packages/patches/icecat-default-search-ddg.patch,
gnu/packages/patches/icecat-disable-sync.patch: Delete files.
* gnu/packages/patches/icecat-gnuzilla-fixes.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adapt accordingly.
* gnu/packages/gnuzilla.scm (icecat-source): Apply the new patch to the
gnuzilla checkout.
(icecat)[native-inputs]: Remove deleted patches.
[arguments]: In the 'wrap-program' phase, remove MOZ_LEGACY_PROFILES=1
from the wrapper.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index db7106c4da..3902f490d0 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -588,6 +588,8 @@ from forcing GEXP-PROMISE."
              (base32
               "1ll3j2kpsfp1f9dxy67fay1cidsng02l8a3a23wdjqkxgrg1cf4g"))))
 
+         (gnuzilla-fixes-patch
+          (local-file (search-patch "icecat-gnuzilla-fixes.patch")))
          (makeicecat-patch
           (local-file (search-patch "icecat-makeicecat.patch"))))
 
@@ -634,6 +636,8 @@ from forcing GEXP-PROMISE."
                 (with-directory-excursion "/tmp/gnuzilla"
                   (make-file-writable "makeicecat")
                   (invoke "patch" "--force" "--no-backup-if-mismatch"
+                          "-p1" "--input" #+gnuzilla-fixes-patch)
+                  (invoke "patch" "--force" "--no-backup-if-mismatch"
                           "-p1" "--input" #+makeicecat-patch)
                   (patch-shebang "makeicecat")
                   (substitute* "makeicecat"
@@ -772,10 +776,6 @@ from forcing GEXP-PROMISE."
        ;;  ,(search-patch "icecat-use-system-graphite2+harfbuzz.patch"))
        ;; ("icecat-use-system-media-libs.patch"
        ;;  ,(search-patch "icecat-use-system-media-libs.patch"))
-       ("icecat-default-search-ddg.patch"
-        ,(search-patch "icecat-default-search-ddg.patch"))
-       ("icecat-disable-sync.patch"
-        ,(search-patch "icecat-disable-sync.patch"))
 
        ("patch" ,(canonical-package patch))
 
@@ -1079,8 +1079,7 @@ from forcing GEXP-PROMISE."
                     (pulseaudio-lib (string-append pulseaudio "/lib")))
                (wrap-program (car (find-files lib "^icecat$"))
                  `("XDG_DATA_DIRS" prefix (,gtk-share))
-                 `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib))
-                 `("MOZ_LEGACY_PROFILES" = ("1")))
+                 `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib)))
                #t))))))
     (home-page "https://www.gnu.org/software/gnuzilla/")
     (synopsis "Entirely free browser derived from Mozilla Firefox")