summary refs log tree commit diff
path: root/gnu/packages/golang-build.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-12 13:47:31 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:49 +0100
commitc2efdad440d0cb9b7919b49ea0663937691e3132 (patch)
treecc75e0aaedf75eb6fb80882102900cb384c340e2 /gnu/packages/golang-build.scm
parent6be3cbad1351ff9d3ecd56e7f2372e9c54d4af7c (diff)
downloadguix-c2efdad440d0cb9b7919b49ea0663937691e3132.tar.gz
gnu: go-golang-org-x-crypto: Update to 0.25.0.
* gnu/packages/golang-build.scm (go-golang-org-x-crypto): Update to 0.25.0.
[propagated-inputs]: Remove go-golang-org-x-net and go-golang-org-x-text.

Change-Id: I5357ee2788764422a50f793c8b06faee371d2453
Diffstat (limited to 'gnu/packages/golang-build.scm')
-rw-r--r--gnu/packages/golang-build.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 200170d9c4..90d13b0ce3 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -90,17 +90,16 @@
 (define-public go-golang-org-x-crypto
   (package
     (name "go-golang-org-x-crypto")
-    (version "0.14.0")
+    (version "0.25.0")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://go.googlesource.com/crypto")
              (commit (string-append "v" version))))
-       (file-name (string-append "go.googlesource.com-crypto-"
-                                 version "-checkout"))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "08124qkp0l0blq6rw68llfbf84kp99255q0yvxyv27c05b0wkh66"))))
+        (base32 "1cnglyy3fhvnnynazfdrikkwcxv3rlxamvfxink2z241lncvwkxy"))))
     (build-system go-build-system)
     (arguments
      '(#:import-path "golang.org/x/crypto"
@@ -111,10 +110,7 @@
          ;; Source-only package
          (delete 'build))))
     (propagated-inputs
-     (list go-golang-org-x-net
-           go-golang-org-x-sys
-           go-golang-org-x-term
-           go-golang-org-x-text))
+     (list go-golang-org-x-sys go-golang-org-x-term))
     (home-page "https://go.googlesource.com/crypto/")
     (synopsis "Supplementary cryptographic libraries in Go")
     (description "This package provides supplementary cryptographic libraries