summary refs log tree commit diff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorBenjamin <benjamin@uvy.fr>2023-11-18 19:17:29 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-08 21:46:22 +0000
commitd6866b6cbee4920439be86916dab3c830746f5ea (patch)
treeea512442aebba45ad7f3083296555d84dfb0e024 /gnu/packages/golang-check.scm
parentff61ca41d903d75cb01fb31b860c9660bbd836cc (diff)
downloadguix-d6866b6cbee4920439be86916dab3c830746f5ea.tar.gz
gnu: Add go-github-com-prashantv-gostub.
* gnu/packages/golang-check.scm (go-github-com-prashantv-gostub): New variable.

Change-Id: I2ffde6cb83e4c7f6b2e412b38341add952803719
Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 324bf47aa7..912444bc8e 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -14,6 +14,7 @@
 ;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2022 ( <paren@disroot.org>
 ;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
 ;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
 ;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
 ;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
@@ -351,6 +352,30 @@ builds on top of Go's builtin @code{testing} library and is complemented by the
 Gomega matcher library.")
     (license license:expat)))
 
+(define-public go-github-com-prashantv-gostub
+  (package
+    (name "go-github-com-prashantv-gostub")
+    (version "1.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/prashantv/gostub")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "035xf5w4fqlicdbbjcflsqflc0z5gmrn6wr7q41xwqfwfpraf9ah"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/prashantv/gostub"))
+    (native-inputs (list go-github-com-stretchr-testify))
+    (home-page "https://github.com/prashantv/gostub")
+    (synopsis "Stubbing library for Go")
+    (description
+     "Package gostub is used for stubbing variables in tests, and resetting the
+original value once the test has been run.")
+    (license license:expat)))
+
 (define-public go-github-com-stretchr-testify
   (package
     (name "go-github-com-stretchr-testify")