summary refs log tree commit diff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-19 02:28:55 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-22 22:02:56 -0400
commitdc01497850dd1af2378736a018df75a2fd603f22 (patch)
treee64fc0d63e610ce0c18d9713c014c77b3c403eb3 /gnu/packages/golang-check.scm
parent4cd78484bbb9625d7ffeaa9bad3471e443e921ee (diff)
downloadguix-dc01497850dd1af2378736a018df75a2fd603f22.tar.gz
gnu: go-github-com-stretchr-testify: Move to (gnu packages golang-check).
* gnu/packages/golang.scm (go-github-com-stretchr-testify): Move from
here...
* gnu/packages/golang-check.scm: ...to here.

* gnu/packages/databases.scm: Add (gnu packages golang-check) module.
* gnu/packages/education.scm: As above...
* gnu/packages/ipfs.scm: As above...
* gnu/packages/irc.scm: As above...
* gnu/packages/mail.scm: As above...
* gnu/packages/textutils.scm: As above...
* gnu/packages/version-control.scm: As above...

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 160fdff6a6..c6b2f3f99e 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1,4 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -31,6 +34,42 @@
 ;;;
 ;;; Code:
 
+(define-public go-github-com-stretchr-testify
+  (package
+    (name "go-github-com-stretchr-testify")
+    (version "1.7.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/stretchr/testify")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0ixgjsvafr3513pz3r6pmgk074s2dxkll0dadvl25gkf30rkmh10"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/stretchr/testify"))
+    (propagated-inputs
+     `(("github.com/davecgh/go-spew" ,go-github-com-davecgh-go-spew)
+       ("github.com/pmezard/go-difflib" ,go-github-com-pmezard-go-difflib)
+       ("github.com/stretchr/objx" ,go-github-com-stretchr-objx)
+       ("gopkg.in/yaml.v3" ,go-gopkg-in-yaml-v3)))
+    (home-page "https://github.com/stretchr/testify")
+    (synopsis "Go helper library for tests and invariant checking")
+    (description "This package provide many tools for testifying that your
+code will behave as you intend.
+
+Features include:
+@itemize
+@item Easy assertions
+@item Mocking
+@item HTTP response trapping
+@item Testing suite interfaces and functions.
+@end itemize")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar