summary refs log tree commit diff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-07-29 01:19:50 +0800
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-16 14:17:32 +0000
commitfd28001a44e725b4da2d29b7eae130d30db5db88 (patch)
treedc280e7eed9e14c32b6f89a92a63154b8b2700a0 /gnu/packages/golang-check.scm
parentb5e008d04cde16453e98c2afaa8087f02a5db79b (diff)
downloadguix-fd28001a44e725b4da2d29b7eae130d30db5db88.tar.gz
gnu: Add go-github-com-alecthomas-assert-v2.
* gnu/packages/golang-check.scm (go-github-com-alecthomas-assert-v2):
New variable.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 93392a82b4..5df3d9ccec 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -94,6 +94,28 @@
 @end itemize\n")
       (license license:expat))))
 
+(define-public go-github-com-alecthomas-assert-v2
+  (package
+    (inherit go-github-com-alecthomas-assert)
+    (name "go-github-com-alecthomas-assert-v2")
+    (version "2.2.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/alecthomas/assert")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "055w46gr47rrn5g2hh7z6hj3x2b8advbcph8gs8szrpzlympyyz0"))))
+    (arguments
+     (list #:go go-1.18
+           #:import-path "github.com/alecthomas/assert/v2"))
+    (propagated-inputs
+     (list go-github-com-alecthomas-repr
+           go-github-com-hexops-gotextdiff))
+    (native-inputs '())))
+
 (define-public go-github-com-cheekybits-is
   (let ((commit "68e9c0620927fb5427fda3708222d0edee89eae9")
         (revision "0"))