summary refs log tree commit diff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-17 00:10:43 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:05 +0000
commit4df431e6cb56c36c557c452c6005c336df731724 (patch)
tree91ff39fc2b6874113e44431497c84a00459d11e5 /gnu/packages/golang-crypto.scm
parentc8640466e6bba3471d6418476c443f4a503bfddb (diff)
downloadguix-4df431e6cb56c36c557c452c6005c336df731724.tar.gz
gnu: go-github-com-gxed-hashland-keccakpg: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-gxed-hashland-keccakpg): Move
from here ...
* gnu/packages/golang-crypto.scm: ... to here.

Change-Id: I000004efa349f0d7548003aeecc98c94669662de
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 9fec753a35..7216f63014 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -272,6 +272,31 @@ providing bidirectional mapping values to their names, plus enum convenience
 for values.")
     (license license:bsd-3)))
 
+(define-public go-github-com-gxed-hashland-keccakpg
+  (let ((commit "d9f6b97f8db22dd1e090fd0bbbe98f09cc7dd0a8")
+        (revision "0"))
+    (package
+      (name "go-github-com-gxed-hashland-keccakpg")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/gxed/hashland")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1q23y4lacsz46k9gmgfw4iwwydw36j2601rbidmmswl94grpc386"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:unpack-path "github.com/gxed/hashland"
+         #:import-path "github.com/gxed/hashland/keccakpg"))
+      (home-page "https://github.com/gxed/hashland")
+      (synopsis "Implements the Keccak (SHA-3) hash algorithm in Go")
+      (description "Package @command{keccak} implements the Keccak (SHA-3)
+hash algorithm.  See http://keccak.noekeon.org.")
+      (license license:expat))))
+
 (define-public go-github-com-jcmturner-aescts-v2
   (package
     (name "go-github-com-jcmturner-aescts-v2")