summary refs log tree commit diff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 23:20:36 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:04 +0000
commit6dc9ac646183673d4b0684756e4661c8a24967d5 (patch)
treeeb9d0e11d96743618b1ceabc20d20bf61b16158a /gnu/packages/golang-crypto.scm
parente946e341df663fddbbaf3d9fbccb3e26eda66cff (diff)
downloadguix-6dc9ac646183673d4b0684756e4661c8a24967d5.tar.gz
gnu: go-github-com-gaukas-godicttls: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-gaukas-godicttls): Move from
here ...
* gnu/packages/golang-crypto.scm: ... to here.

Change-Id: I19e4a52a213469174ab2a7048abeff6dbf7f715c
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 36475ce9d4..22593aff19 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -91,6 +91,29 @@ Bernstein.  The most common ChaCha variant is ChaCha20 (20 rounds).  ChaCha20
 is standardized in RFC 7539.")
       (license license:expat))))
 
+(define-public go-github-com-gaukas-godicttls
+  (package
+    (name "go-github-com-gaukas-godicttls")
+    (version "0.0.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/gaukas/godicttls")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0n9i0b9nbwq7ms36r34kfc346prrif78hhp55gmbkvlgvsc3m2af"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/gaukas/godicttls"))
+    (home-page "https://github.com/gaukas/godicttls")
+    (synopsis "Dictionary for TLS")
+    (description "This package provides a dictionary for TLS written in Go
+providing bidirectional mapping values to their names, plus enum convenience
+for values.")
+    (license license:bsd-3)))
+
 (define-public go-github-com-libp2p-go-libp2p-crypto
   (let ((commit "7240b40a3ddc47c4d17c15baabcbe45e5219171b")
         (revision "0"))