summary refs log tree commit diff
path: root/gnu/packages/golang-maths.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-29 20:34:40 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-03 22:23:21 +0100
commitbcad85a80e833471c2b6453ea86b33535aee0853 (patch)
treea944d974f54aa75ae4481433f16a7cefff9da275 /gnu/packages/golang-maths.scm
parentada945251cd31dbffc4e8250f41343294cfaa1b4 (diff)
downloadguix-bcad85a80e833471c2b6453ea86b33535aee0853.tar.gz
gnu: Add go-github-com-shopspring-decimal.
* gnu/packages/golang-maths.scm (go-github-com-shopspring-decimal): New variable.

Change-Id: I52ba58d05be9f631e5c53ccf7c30a977d7fe66b3
Diffstat (limited to 'gnu/packages/golang-maths.scm')
-rw-r--r--gnu/packages/golang-maths.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang-maths.scm b/gnu/packages/golang-maths.scm
index dfb29abea4..2348255119 100644
--- a/gnu/packages/golang-maths.scm
+++ b/gnu/packages/golang-maths.scm
@@ -57,6 +57,37 @@
      "This package provides a statistical library for Golang.")
     (license license:expat)))
 
+(define-public go-github-com-shopspring-decimal
+  (package
+    (name "go-github-com-shopspring-decimal")
+    (version "1.4.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/shopspring/decimal")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1p1iz0ybsjvc8k3w6lf92drs51fgrcbz0ib1p4ihp3gmdq5rnzjk"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/shopspring/decimal"))
+    (home-page "https://github.com/shopspring/decimal")
+    (synopsis "Arbitrary-precision fixed-point decimal numbers in Golang")
+    (description
+     "Package decimal implements an arbitrary precision fixed-point decimal.
+Features:
+@itemize
+@item the zero-value is 0, and is safe to use without initialization
+@item addition, subtraction, multiplication with no loss of precision
+@item division with specified precision
+@item database/sql serialization/deserialization
+@item JSON and XML serialization/deserialization
+@end itemize")
+    (license license:expat)))
+
 ;;;
 ;;; Executables:
 ;;;