summary refs log tree commit diff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-21 23:15:04 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 20:46:47 +0100
commiteadbf482b74b3c0da9415c7216ab35ceb81e565a (patch)
treef2d9c7063a15f6c5edf5b38cfc6e6a5bd6bd9018 /gnu/packages/golang-web.scm
parente61d34b8b0f0d17f3b44f1d44ba75a35c88df298 (diff)
downloadguix-eadbf482b74b3c0da9415c7216ab35ceb81e565a.tar.gz
gnu: Add go-github-com-aws-aws-lambda-go.
* gnu/packages/golang-web.scm (go-github-com-aws-aws-lambda-go): New variable.

Change-Id: I5abb8225f0c36232e8fbd6c37763ae30f842eab2
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 8f00b0e351..fbdef8a35f 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -270,6 +270,41 @@ the parse trees produced by the html package.")
 connections from a single physical connection.")
     (license license:expat)))
 
+(define-public go-github-com-aws-aws-lambda-go
+  (package
+    (name "go-github-com-aws-aws-lambda-go")
+    (version "1.47.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/aws/aws-lambda-go")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0xki0n3va9nr6dmlgrb8zarkccx5jba6ig6g8zxcznw3rlllf1zv"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/aws/aws-lambda-go"
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; XXX: Workaround for go-build-system's lack of Go modules support.
+          (delete 'build)
+          (replace 'check
+            (lambda* (#:key tests? import-path #:allow-other-keys)
+              (when tests?
+                (with-directory-excursion (string-append "src/" import-path)
+                  (invoke "go" "test" "-v" "./..."))))))))
+    (native-inputs
+     (list go-github-com-stretchr-testify))
+    (home-page "https://github.com/aws/aws-lambda-go")
+    (synopsis "AWS Lambda for Go")
+    (description
+     "Libraries, samples, and tools to help Go developers develop AWS Lambda
+functions.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-aws-aws-sdk-go
   (package
     (name "go-github-com-aws-aws-sdk-go")