summary refs log tree commit diff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-30 21:20:04 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-30 22:58:22 +0000
commitfb2b72a5f35e134ee641c8d1fa1e48bd7696ef43 (patch)
tree44e0b8188945e5216651c582729ee1185c3b278c /gnu/packages/golang-web.scm
parentf6bbee5f05be8f297aea65013b9f2c679c6bf9aa (diff)
downloadguix-fb2b72a5f35e134ee641c8d1fa1e48bd7696ef43.tar.gz
gnu: go-github-com-go-jose-go-jose-v3: Move to (gnu packages golang-web).
Drop inheritance from go-gopkg-in-square-go-jose-v2 as it's archived by
the owner on Feb 27, 2023.

* gnu/packages/golang.scm (go-github-com-go-jose-go-jose-v3): Move from
here ...
* gnu/packages/golang-web.scm: ... to here.

Change-Id: I67838e18a43d93e5ae3b62e9645b7d22cf474103
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index dfa1f862dc..dd84962110 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -577,6 +577,35 @@ logging system.")
 decompose request handling into many smaller layers.")
     (license license:expat)))
 
+(define-public go-github-com-go-jose-go-jose-v3
+  (package
+    (name "go-github-com-go-jose-go-jose-v3")
+    (version "3.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/go-jose/go-jose")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1fnw0p49wc9gmd2xcji2x9jf97dgg9igagd5m6bmq3nw9jjfqdc5"))))
+    (build-system go-build-system)
+    (arguments
+     '( #:import-path "github.com/go-jose/go-jose/v3"))
+    (propagated-inputs
+     (list go-golang-org-x-crypto))
+    (native-inputs
+     (list go-github-com-google-go-cmp-cmp
+           go-github-com-stretchr-testify))
+    (home-page "https://github.com/go-jose/go-jose")
+    (synopsis "Implementation of JOSE standards (JWE, JWS, JWT) in Go")
+    (description
+     "This package provides a Golang implementation of the Javascript Object
+Signing and Encryption set of standards.  This includes support for JSON Web
+Encryption, JSON Web Signature, and JSON Web Token standards.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-go-telegram-bot-api-telegram-bot-api
   (package
     (name "go-github-com-go-telegram-bot-api-telegram-bot-api")