summary refs log tree commit diff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-16 15:23:33 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-19 23:32:32 +0000
commit73eb26cbd7eb7d1abc906812cc46ae96906a6a9c (patch)
tree6bc5186284047d4faf83b2a18205e0196a47e833 /gnu/packages/golang-xyz.scm
parentee79286031e87fc7f2e5477a56a9c49b74971080 (diff)
downloadguix-73eb26cbd7eb7d1abc906812cc46ae96906a6a9c.tar.gz
gnu: go-github-com-alecthomas-chroma: Update to 0.10.0.
* gnu/packages/golang-xyz.scm (go-github-com-alecthomas-chroma): Update to 0.10.0.
[native-inputs]: Remove go-github-com-alecthomas-assert,
go-github-com-alecthomas-colour, go-github-com-alecthomas-repr,
go-github-com-mattn-go-isatty, and go-github-com-sergi-go-diff; add
go-github-com-stretchr-testify.

Change-Id: I9d72bbdeb97a3c94545ff08d356c5e568fe173c6
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index a31cd74b3d..cc1b68cf7d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -83,7 +83,7 @@ substitution.")
 (define-public go-github-com-alecthomas-chroma
   (package
     (name "go-github-com-alecthomas-chroma")
-    (version "0.8.0")
+    (version "0.10.0")
     (source
      (origin
        (method git-fetch)
@@ -92,17 +92,13 @@ substitution.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "066a6rdmf670d3v5sc7chbn7db09ldgxjympb03pcqwk644dixb1"))))
+        (base32 "0hjzb61m5lzx95xss82wil9s8f9hbw1zb3jj73ljfwkq5lqk76zq"))))
     (build-system go-build-system)
     (arguments
      `(#:import-path "github.com/alecthomas/chroma"))
     (native-inputs
      (list go-github-com-dlclark-regexp2
-           go-github-com-alecthomas-assert
-           go-github-com-alecthomas-colour
-           go-github-com-alecthomas-repr
-           go-github-com-mattn-go-isatty
-           go-github-com-sergi-go-diff))
+           go-github-com-stretchr-testify))
     (home-page "https://github.com/alecthomas/chroma/")
     (synopsis "General purpose syntax highlighter in pure Go")
     (description