summary refs log tree commit diff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-03-09 01:21:55 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-16 23:27:03 +0000
commit85c816c7ad0c9486fe71c72a5c15d6e625da7458 (patch)
treed23c102595f6191c1e336bbb4d3a9900dd956c0a /gnu/packages/golang-xyz.scm
parent32fd2776429b5cd1fb5094532f490e5d31415f6e (diff)
downloadguix-85c816c7ad0c9486fe71c72a5c15d6e625da7458.tar.gz
gnu: Add go-github-com-whyrusleeping-go-sysinfo.
* gnu/packages/golang-xyz.scm (go-github-com-whyrusleeping-go-sysinfo): New
  variable.

Change-Id: I73cd3fa1ab3a73545121bb3a047795ca2850c0f7
Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index cd3fbb8098..d1e0666ea5 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1810,6 +1810,34 @@ query information regarding the number of CPUs available to the system.")
 weighted moving averages}.")
     (license license:expat)))
 
+(define-public go-github-com-whyrusleeping-go-sysinfo
+  (package
+    (name "go-github-com-whyrusleeping-go-sysinfo")
+    (version "0.0.0-20190219211824-4a357d4b90b1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/whyrusleeping/go-sysinfo")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0s6yjp9incc579wbbga33vq0hcanv8j2xh9l90ya0r4fihz39jiq"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/whyrusleeping/go-sysinfo"))
+    (propagated-inputs
+     (list go-github-com-dustin-go-humanize))
+    (home-page "https://github.com/whyrusleeping/go-sysinfo")
+    (synopsis "Package to extract system information")
+    ;; There is not much information provided by the project, see
+    ;; <https://github.com/whyrusleeping/go-sysinfo/issues>.
+    (description
+     "This packages provides a basic system stats like @code{DiskUsage} and
+@code{MemoryInfo}.")
+    (license license:expat)))
+
 (define-public go-go-uber-org-automaxprocs
   (package
     (name "go-go-uber-org-automaxprocs")