summary refs log tree commit diff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-02-10 22:28:27 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 09:35:58 +0100
commit89e844d82586a56218ec65c3cc945e4a80093c7c (patch)
treeacf25da43a6474dc714705a18e98930dfec3b8f6 /gnu/packages/golang-xyz.scm
parent85df67d365e710c19a57415a5db6ac08aefb39b3 (diff)
downloadguix-89e844d82586a56218ec65c3cc945e4a80093c7c.tar.gz
gnu: go-go-etcd-io-bbolt: Move to (gnu packages golang-xyz).
* gnu/packages/databases.scm (go-go-etcd-io-bbolt): Move from here ...
* gnu/packages/golang-xyz.scm: ... to here.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Change-Id: I52e6ea227c417c1997210ecc22725387143df32f
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index abcd18dd67..44b3f54325 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4105,6 +4105,34 @@ string.  The string can be a string retorned for @code{time.Duration} or a
 similar string with weeks or days too.")
     (license license:bsd-3)))
 
+(define-public go-go-etcd-io-bbolt
+  (package
+    (name "go-go-etcd-io-bbolt")
+    (version "1.3.6")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/etcd-io/bbolt")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "0pj5245d417za41j6p09fmkbv05797vykr1bi9a6rnwddh1dbs8d"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "go.etcd.io/bbolt"
+       ;; Extending the test timeout to 30 minutes still times out on aarch64.
+       #:tests? ,(not target-arm?)))
+    (propagated-inputs
+     (list go-golang-org-x-sys))
+    (home-page "https://go.etcd.io/bbolt")
+    (synopsis "Embedded key/value database for Go")
+    (description "Bolt is a pure Go key/value store inspired by Howard Chu's
+LMDB project.  The goal of the project is to provide a simple, fast, and
+reliable database for projects that don't require a full database server such as
+Postgres or MySQL.")
+    (license license:expat)))
+
 (define-public go-go-uber-org-atomic
   (package
     (name "go-go-uber-org-atomic")