summary refs log tree commit diff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 14:05:10 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 14:21:00 +0000
commit8ed9ce9d0070b854f0aadc6626e624ba2156c112 (patch)
tree905d8900e8b73575563c897760ab70b19ca74eea /gnu/packages/golang-xyz.scm
parent9358929873d235e01461a45b8a2a9789fdb6c5f0 (diff)
downloadguix-8ed9ce9d0070b854f0aadc6626e624ba2156c112.tar.gz
gnu: go-github-com-danwakefield-fnmatch: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-danwakefield-fnmatch): Move
from here ...
* gnu/packages/golang-xyz.scm: ... to here.

* gnu/packages/mail.scm: Add (gnu packages golang-xyz) module.

Change-Id: I2d5d0565f4c758f49032cadfa1dcca7e884a577b
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 8e34c34e7b..e1ac32273c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -784,6 +784,33 @@ of unit files.")))
 metrics to Graphite.")
     (license license:bsd-2)))
 
+(define-public go-github-com-danwakefield-fnmatch
+  (let ((commit "cbb64ac3d964b81592e64f957ad53df015803288")
+        (revision "0"))
+    (package
+      (name "go-github-com-danwakefield-fnmatch")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/danwakefield/fnmatch")
+               (commit commit)))
+         (sha256
+          (base32 "0cbf511ppsa6hf59mdl7nbyn2b2n71y0bpkzbmfkdqjhanqh1lqz"))
+         (file-name (git-file-name name version))))
+      (build-system go-build-system)
+      (arguments
+       (list
+        #:import-path "github.com/danwakefield/fnmatch"))
+      (home-page "https://github.com/danwakefield/fnmatch")
+      (synopsis "Updated clone of kballards golang fnmatch gist")
+      (description
+       "This package provides string-matching based on BSD fnmatch.3.  It is an
+updated clone of kballards golang fnmatch
+gist (https://gist.github.com/kballard/272720).")
+      (license license:bsd-2))))
+
 (define-public go-github-com-dave-jennifer
   (package
     (name "go-github-com-dave-jennifer")