summary refs log tree commit diff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-02-14 23:55:37 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-19 23:32:32 +0000
commit930692feb0d26c2d9ab5715a2a84196eef13f221 (patch)
tree127e792cdebe45fbf6a56eac3bac2f4e8d6c2ec2 /gnu/packages/golang-xyz.scm
parent084ce22aa336cc92104d586ede30b583fb9e6fef (diff)
downloadguix-930692feb0d26c2d9ab5715a2a84196eef13f221.tar.gz
gnu: Add go-github-com-dustin-gojson.
* gnu/packages/golang.scm (go-github-com-dustin-gojson): New variable.

Change-Id: Ifc3df4e7a2cdf21bf0725a848123930d61d048e3
Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index b6e582fdc5..d6aa5d0538 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -519,6 +519,42 @@ Mark} detection.")
 atimes for files.")
     (license license:expat)))
 
+(define-public go-github-com-dustin-gojson
+  (package
+    (name "go-github-com-dustin-gojson")
+    (version "v0.0.0-20160307161227-2e71ec9dd5ad")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/dustin/gojson")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1vrmmyn7l568l1k71mxd54iqf3d54pn86cf278i374j86jn0bdxf"))
+       (modules '((guix build utils)))
+       (snippet '(begin
+                   ;; Fix the library to work with go-1.21.
+                   (substitute* "decode.go"
+                     (("trying to unmarshal unquoted value into")
+                      "trying to unmarshal unquoted value %v into"))
+                   (substitute* "decode_test.go"
+                     (("t.Fatalf\\(\"Unmarshal: %v\"\\)")
+                      "t.Fatalf(\"Unmarshal: %v\", data)")) ;))))
+                   (substitute* "scanner.go"
+                     (("s := strconv.Quote\\(string\\(c\\)\\)")
+                      "s := strconv.QuoteRune(rune(c))"))))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/dustin/gojson"
+       #:go ,go-1.21))
+    (home-page "https://github.com/dustin/gojson")
+    (synopsis "Extended Golang's @code{encoding/json} module with the public scanner API")
+    (description
+     "This package provides a fork of Golang's @code{encoding/json} with the
+scanner API made public.")
+    (license license:bsd-3)))
+
 (define-public go-github-com-elliotchance-orderedmap
   (package
     (name "go-github-com-elliotchance-orderedmap")