summary refs log tree commit diff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorDominic Martinez <dom@dominicm.dev>2024-02-11 19:28:21 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-12 23:33:23 +0000
commit9a938589d1bcc97cf82577d73c300c986ce59594 (patch)
treea7e5b6b151cbd053e5b183d774904b12719e2a5c /gnu/packages/golang-xyz.scm
parent7e4aebc39bf53162027dc5b4f679aa44f89752b7 (diff)
downloadguix-9a938589d1bcc97cf82577d73c300c986ce59594.tar.gz
gnu: Add go-github-com-songgao-water.
* gnu/packages/golang-xyz.scm (go-github-com-songgao-water): New variable.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Change-Id: If08b2994f932b604d2d537e7d3d02e90934542fb
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index aa3df0a152..dd08f19b92 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -322,6 +322,30 @@ library which posts the metrics to the Prometheus client registry and just
 updates the registry.")
     (license license:asl2.0)))
 
+(define-public go-github-com-songgao-water
+  (package
+    (name "go-github-com-songgao-water")
+    (version "0.0.0-20200317203138-2b4b6d7c09d8")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/songgao/water")
+               (commit (go-version->git-ref version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "1k5aildfszp6x66jzar4y36lic8ijkb5020hfaivpvq3bnwdiikl"))))
+    (build-system go-build-system)
+    (arguments '(#:tests? #f ; Tests require network interface access
+                 #:import-path "github.com/songgao/water"))
+    (home-page "https://github.com/songgao/water")
+    (synopsis "Simple network TUN/TAP library")
+    (description
+      "This package provides a simple TUN/TAP interface library for Go that
+efficiently works with standard packages like @code{io}, @code{bufio}, etc..
+Use waterutil with it to work with TUN/TAP packets/frames.")
+    (license license:bsd-3)))
+
 (define-public go-go-uber-org-automaxprocs
   (package
     (name "go-go-uber-org-automaxprocs")