summary refs log tree commit diff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-12 22:12:50 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-12 23:33:23 +0000
commit9cdcf7c6f909cec5af8a34bb4f2226e1ab507ee7 (patch)
tree52a868c2afb7ccc9a37ac958bf550140a913c230 /gnu/packages/golang-xyz.scm
parent3da105865c53c80c2ed7ac6e54dfb320d1ef06d9 (diff)
downloadguix-9cdcf7c6f909cec5af8a34bb4f2226e1ab507ee7.tar.gz
gnu: go-github-com-stathat-go: Move to golang-xyz.
* gnu/packages/syncthing.scm (go-github-com-stathat-go): Move from here ...
* gnu/packages/golang-xyz.scm: ... to here.

Change-Id: I804043f512b60665233fba61da3f2225042d8d65
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 6a26cd1b06..4eb52d427d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -429,6 +429,29 @@ efficiently works with standard packages like @code{io}, @code{bufio}, etc..
 Use waterutil with it to work with TUN/TAP packets/frames.")
     (license license:bsd-3)))
 
+(define-public go-github-com-stathat-go
+  (let ((commit "74669b9f388d9d788c97399a0824adbfee78400e")
+        (revision "0"))
+    (package
+      (name "go-github-com-stathat-go")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/stathat/go")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1zzlsl24dyr202qkr2pay22m6d0gb7ssms77wgdx0r0clgm7dihw"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/stathat/go"))
+      (synopsis "Post statistics to StatHat")
+      (description "This is a Go package for posting to a StatHat account.")
+      (home-page "https://github.com/stathat/go")
+      (license license:expat))))
+
 (define-public go-go-uber-org-automaxprocs
   (package
     (name "go-go-uber-org-automaxprocs")