summary refs log tree commit diff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-21 12:30:33 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-21 13:43:26 +0100
commitefd3024d732e3a9d93eedcb89fcef2ac71a0978d (patch)
treea8e90f65db79a9b6e330a63b2c73ed6187afe934 /gnu/packages/golang-xyz.scm
parent72453bfb0ca5ec1eabf0ace88673a5581bf48219 (diff)
downloadguix-efd3024d732e3a9d93eedcb89fcef2ac71a0978d.tar.gz
gnu: Add go-msgio.
* gnu/packages/golang-xyz.scm (go-msgio): New variable.

Change-Id: I3bb5fff6110a36694865c9885b42bc356902bbea
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 5c63c8fe17..0a67bfa23c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -5940,6 +5940,18 @@ tool."))
 Trace/Debug/Info/Warn/Error methods on @code{hclog.Logger} are used
 correctly.")))
 
+(define-public go-msgio
+  (package
+    (inherit go-github-com-libp2p-go-msgio)
+    (name "go-msgio")
+    (arguments
+     (list
+      #:tests? #f ; no tests
+      #:install-source? #f
+      #:import-path "github.com/libp2p/go-msgio/msgio"
+      #:unpack-path "github.com/libp2p/go-msgio"))
+    (synopsis "CLI tool to wrap messages with msgio header.")))
+
 (define-public go-numcpus
   (package
     (inherit go-github-com-tklauser-numcpus)