summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-15 23:14:45 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-22 09:53:56 +0200
commit03baf02e6f2ad81cc30b25762d702a343a775f2c (patch)
treed7740e43951f607618aedbf4655d4cb430b355fe /gnu/packages/golang.scm
parentcb380998395b4b6f64dfaed6de5ced8c8c0682aa (diff)
downloadguix-03baf02e6f2ad81cc30b25762d702a343a775f2c.tar.gz
gnu: Add go-github-com-pbnjay-memory.
* gnu/packages/golang.scm (go-github-com-pbnjay-memory): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4a3b50e588..03863529c7 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3597,3 +3597,29 @@ through the life of the application.  Currently x86 / x64 (AMD64) is supported,
 and no external C (cgo) code is used, which should make the library very eas
 to use.")
     (license license:expat)))
+
+(define-public go-github-com-pbnjay-memory
+  (let ((commit "974d429e7ae40c89e7dcd41cfcc22a0bfbe42510")
+        (revision "1"))
+    (package
+      (name "go-github-com-pbnjay-memory")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/pbnjay/memory")
+                       (commit commit)))
+                (file-name (string-append "go-github-com-pbnjay-memory-"
+                                          version "-checkout"))
+                (sha256
+                 (base32
+                  "0kazg5psdn90pqadrzma5chdwh0l2by9z31sspr47gx93fhjmkkq"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/pbnjay/memory"))
+      (home-page "https://github.com/gedex/inflector")
+      (synopsis "Go library to report total system memory")
+      (description "@code{memory} provides a single method reporting total
+physical system memory accessible to the kernel.  It does not account for memory
+used by other processes.")
+      (license license:bsd-3))))