summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorLu Hui <luhux76@gmail.com>2022-01-03 12:54:50 +0800
committerLudovic Courtès <ludo@gnu.org>2022-01-09 23:17:17 +0100
commit04f18d65771d3ceae5c0b67312a59a2e521befb9 (patch)
tree12c4eb0d5d1fef76122087b3b4d30338e37150da /gnu/packages/golang.scm
parent7f20e59a13a6acc3331e04185b8f1ed2538dcd0a (diff)
downloadguix-04f18d65771d3ceae5c0b67312a59a2e521befb9.tar.gz
gnu: Add go-github-com-dreamacro-go-shadowsocks2
* gnu/packages/golang.scm (go-github-com-dreamacro-go-shadowsocks2): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6293c00362..5799d927ea 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -32,6 +32,7 @@
 ;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
 ;;; Copyright © 2021 Chadwain Holness <chadwainholness@gmail.com>
 ;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2021 Lu Hui <luhux76@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -9266,3 +9267,33 @@ newlines until a non-newline.")
        "This library provides unit multipliers and functions for Go.")
       (home-page "https://github.com/alecthomas/units")
       (license license:expat))))
+
+(define-public go-github-com-dreamacro-go-shadowsocks2
+  (package
+    (name "go-github-com-dreamacro-go-shadowsocks2")
+    (version "0.1.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Dreamacro/go-shadowsocks2")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0sjr3r77fav6q0ii6dnp4px9gaz7cq861a0yxppvb6a58420bx3h"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "github.com/Dreamacro/go-shadowsocks2"))
+    (propagated-inputs (list go-golang-org-x-crypto))
+    (home-page "https://github.com/Dreamacro/go-shadowsocks2")
+    (synopsis "Shadowsocks implementation in Go")
+    (description
+     "This package is @code{shadowsocks} implementation in Go
+
+Features:
+@itemize
+@item SOCKS5 proxy
+@item Support for Netfilter TCP redirect (IPv6 should work but not tested)
+@item UDP tunneling (e.g. relay DNS packets)
+@item TCP tunneling (e.g. benchmark with iperf3)
+@end itemize")
+    (license license:asl2.0)))