summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-19 02:29:06 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-22 22:17:30 -0400
commit1261ca098b81b61ed2907c367a05077da591b29d (patch)
treea4ae7320b75864d43d224a349f74539ff5259aaf /gnu/packages/golang.scm
parenteeb397018d5a52a074ae0432a9beb4f1af020403 (diff)
downloadguix-1261ca098b81b61ed2907c367a05077da591b29d.tar.gz
gnu: go-github-com-frankban-quicktest: Move to (gnu packages golang-check).
* gnu/packages/golang-check.scm (go-github-com-frankban-quicktest): Move
from here...
* gnu/packages/golang.scm: ... to here.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d43b43f905..8860ec50fe 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10799,32 +10799,6 @@ is unchanged.  This package contains a series of small enhancements and
 additions.")
       (license license:bsd-3))))
 
-(define-public go-github-com-frankban-quicktest
-  (package
-    (name "go-github-com-frankban-quicktest")
-    (version "1.11.1")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/frankban/quicktest")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "0b1b44b2hli2p969gqz30z8v9z6ahlklpqzi17nwk1lsjz9yv938"))))
-    (build-system go-build-system)
-    (arguments
-     '(#:import-path "github.com/frankban/quicktest"))
-    (propagated-inputs
-     (list go-github-com-google-go-cmp-cmp go-github-com-kr-pretty))
-    (home-page "https://github.com/frankban/quicktest")
-    (synopsis "Quick helpers for testing Go applications")
-    (description
-     "Package quicktest provides a collection of Go helpers for writing
-tests.")
-    (license license:expat)))
-
 (define-public go-github-com-bep-golibsass
   (package
     (name "go-github-com-bep-golibsass")