summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:34:46 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:14 -0500
commit13ab4abe98f1a88256d4ecd9b3ee3cb026515f4e (patch)
tree511692cdb6223f70cb1ef2d2980cbd2846cc4623 /gnu/packages/golang.scm
parent7b2c29095672dd330b17ccabc01128a7e4f45924 (diff)
downloadguix-13ab4abe98f1a88256d4ecd9b3ee3cb026515f4e.tar.gz
gnu: go-github-com-gorilla-websocket: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-gorilla-websocket): Move from
here...
* gnu/packages/golang-web.scm: ...to here.

* gnu/packages/ipfs.scm: Add (gnu packages golang-web) module.

Change-Id: I844738ec0b178a6a1746b01659c93a20919c2736
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm21
1 files changed, 0 insertions, 21 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 52168b93cb..9fe55bc551 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12909,27 +12909,6 @@ to use in various HTML contexts and with various DOM APIs.")
 using shell-style rules for quoting and commenting.")
     (license license:asl2.0)))
 
-(define-public go-github-com-gorilla-websocket
-  (package
-    (name "go-github-com-gorilla-websocket")
-    (version "1.5.0")
-    (home-page "https://github.com/gorilla/websocket")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url home-page)
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1xrr6snvs9g1nzxxg05w4i4pq6k1xjljl5mvavd838qc468n118i"))))
-    (build-system go-build-system)
-    (arguments
-     `(#:import-path "github.com/gorilla/websocket"))
-    (synopsis "Fast WebSocket implementation for Go")
-    (description "Gorilla WebSocket is a Go implementation of the WebSocket protocol.")
-    (license license:bsd-2)))
-
 (define-public go-github-com-sourcegraph-jsonrpc2
   (package
     (name "go-github-com-sourcegraph-jsonrpc2")