summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-02-11 01:24:12 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 21:26:39 +0000
commit14ea50518d26060b12149078371b4a50e0dee938 (patch)
tree809f1fe9ca90a061733fe2fa1309e940790795be /gnu/packages/golang.scm
parent00e0071391f060bd8888dd31ae744e5126c0d2c4 (diff)
downloadguix-14ea50518d26060b12149078371b4a50e0dee938.tar.gz
gnu: go-github-com-charmbracelet-bubbletea: Remove examples.
* gnu/packages/golang.scm (go-github-com-charmbracelet-bubbletea): Remove
examples and tutorials.
[arguments] <#:phases>: Add remove-examples phase.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Change-Id: Ic4ed211ae0fa0849770264ccc950a73d55cd70c4
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 50a73a1ae3..a91dca5206 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9707,7 +9707,14 @@ string.")
          "1105cggi5fwqx69m0vrhgwx6kaw82w4ahn58sj0a81603c4yvrk0"))))
     (build-system go-build-system)
     (arguments
-     `(#:import-path "github.com/charmbracelet/bubbletea"))
+     (list
+      #:import-path "github.com/charmbracelet/bubbletea"
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'unpack 'remove-examples
+                     (lambda* (#:key import-path #:allow-other-keys)
+                       (with-directory-excursion (string-append "src/" import-path)
+                         (for-each delete-file-recursively
+                                   '("examples" "tutorials"))))))))
     (propagated-inputs
      `(("github.com/mattn/go-isatty" ,go-github-com-mattn-go-isatty)
        ("github.com/muesli/termenv" ,go-github-com-muesli-termenv)