summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 15:46:20 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 16:58:43 +0100
commit1a1821ff206c065e2c80294c9ab9295e23aa777a (patch)
treeea98ccdbb536f426120783116ba1b0111fbb1c8b /gnu/packages/golang.scm
parent5f82b1773a30cbaf2844722b02c1c91942cd98df (diff)
downloadguix-1a1821ff206c065e2c80294c9ab9295e23aa777a.tar.gz
gnu: go-go-uber-org-multierr: Move to golang-xyz.
* gnu/packages/golang.scm (go-go-uber-org-multierr): Move from here ...
* gnu/packages/golang-xyz.scm: ... to here.

Change-Id: If343d3b97a4b625424ee846c903e5db1b91fcc23
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 611a9e883b..269bcaa3e4 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8454,32 +8454,6 @@ Gemini clients and servers.")
 @code{getopt} for Go.")
     (license license:bsd-3)))
 
-(define-public go-go-uber-org-multierr
-  (package
-    (name "go-go-uber-org-multierr")
-    (version "1.6.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/uber-go/multierr")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "162941s8f6a9x2w04qm4qa3zz0zylwag9149hywrj9ibp2nzcsqz"))))
-    (build-system go-build-system)
-    (arguments
-     '(#:import-path "go.uber.org/multierr"))
-    (native-inputs
-     (list go-github-com-stretchr-testify))
-    (propagated-inputs
-     (list go-go-uber-org-atomic))
-    (home-page "https://go.uber.org/multierr")
-    (synopsis "Error combination for Go")
-    (description
-     "@code{multierr} allows combining one or more Go errors together.")
-    (license license:expat)))
-
 (define-public gofumpt
   (package
     (name "gofumpt")