summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-19 02:28:59 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-22 22:17:28 -0400
commit28a9e296f8fad8ee4ddc93987d80fb484c6c79fa (patch)
tree069816addd77a1c6342e800ad852afd6d436bf1c /gnu/packages/golang.scm
parent4bb570a29897ed1889f95f72a64fb741535c4521 (diff)
downloadguix-28a9e296f8fad8ee4ddc93987d80fb484c6c79fa.tar.gz
gnu: go-github-com-jacobsa-oglematchers: Move to (gnu packages golang-check).
* gnu/packages/golang.scm (go-github-com-jacobsa-oglematchers): Move
from here...
* gnu/packages/golang-check.scm: ... to here.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 794e5f0f49..afc1a9bd30 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1311,34 +1311,6 @@ networks where it would otherwise be blocked or heavily throttled.")
 not included in the Go standard library.")
       (license license:asl2.0))))
 
-(define-public go-github-com-jacobsa-oglematchers
-  (let ((commit "141901ea67cd4769c6800aa7bfdfc558fa22bda5")
-        (revision "0"))
-    (package
-      (name "go-github-com-jacobsa-oglematchers")
-      (version (git-version "0.0.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/jacobsa/oglematchers")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "09ff5x6vbhd9zl1z4yzyk573ifh16rry38q1rx986kbz4hqkmniq"))))
-      (build-system go-build-system)
-      (arguments
-       '(#:import-path "github.com/jacobsa/oglematchers"
-         ;; break loop with with go-github-com-jacobsa-ogletest
-         #:tests? #f))
-      (home-page "https://github.com/jacobsa/oglematchers")
-      (synopsis "Matchers for Go testing framework")
-      (description
-       "Package oglematchers provides a set of matchers useful in a testing or mocking
-framework.  These matchers are inspired by and mostly compatible with Google
-Test for C++ and Google JS Test.")
-      (license license:asl2.0))))
-
 (define-public go-github-com-jacobsa-ogletest
   (let ((commit "80d50a735a1108a2aeb7abc4a988d183f20c5292")
         (revision "0"))