summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 23:30:57 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:04 +0000
commit7ab2ae0ee7d24a8efcafcff958758800fcaa7410 (patch)
tree920a1a16b99dd347312d67f55f3dbf578503845e /gnu/packages/golang.scm
parentf7ca047b6dd6f7d43a927f1b189be7a3a4e04581 (diff)
downloadguix-7ab2ae0ee7d24a8efcafcff958758800fcaa7410.tar.gz
gnu: go-github-com-aperturerobotics-jacobsa-crypto: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-aperturerobotics-jacobsa-crypto):
Move from here ...
* gnu/packages/golang-crypto.scm: ... to here.

* gnu/packages/file-systems.scm: Add (gnu packages golang-crypto) to
used modules.

Change-Id: I9562a3a3054b7d361758c5e5984891970f191ada
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a44427e5d4..4c3b90d4b1 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1420,37 +1420,6 @@ networks where it would otherwise be blocked or heavily throttled.")
        "This is a repository containing Go bindings for writing FUSE file systems.")
       (license license:bsd-3))))
 
-(define-public go-github-com-aperturerobotics-jacobsa-crypto
-  (let ((commit "b1eb679742a8deed015a4406384eea6bd985d08a")
-        (revision "0"))
-    (package
-      (name "go-github-com-aperturerobotics-jacobsa-crypto")
-      (version (git-version "1.0.1" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/aperturerobotics/jacobsa-crypto")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "16dxigj8m6q18xqsy72iq287rh4fw0y0b9yqlw0qkclb8379n1z2"))))
-      (build-system go-build-system)
-      (arguments
-       (list #:import-path "github.com/aperturerobotics/jacobsa-crypto"
-             ;; Source-only package.
-             #:tests? #f
-             #:phases
-             #~(modify-phases %standard-phases
-                 ;; Source-only package.
-                 (delete 'build))))
-      (home-page "https://github.com/aperturerobotics/jacobsa-crypto")
-      (synopsis "Cryptography missing from the Go standard library")
-      (description
-       "This repository contains Go packages related to cryptographic standards that are
-not included in the Go standard library.")
-      (license license:asl2.0))))
-
 (define-public go-github-com-jacobsa-reqtrace
   (let ((commit "245c9e0234cb2ad542483a336324e982f1a22934")
         (revision "0"))