summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-19 02:28:56 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-22 22:03:04 -0400
commit7d40f11e0125a70c6635b56fc327879f63345bbc (patch)
treeba251958eba46d671ad52423b43de1bb71dd86aa /gnu/packages/golang.scm
parentdc01497850dd1af2378736a018df75a2fd603f22 (diff)
downloadguix-7d40f11e0125a70c6635b56fc327879f63345bbc.tar.gz
gnu: go-github-com-jacobsa-oglemock: Move to (gnu packages golang-check)
* gnu/packages/golang.scm (go-github-com-jacobsa-oglemock): Move from here...
* gnu/packages/golang-check.scm: ... to here.

* gnu/packages/file-systems.scm: Add use-module (gnu-packages golang-check).

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9a7f60fc0a..05a68cdcc9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1339,35 +1339,6 @@ framework.  These matchers are inspired by and mostly compatible with Google
 Test for C++ and Google JS Test.")
       (license license:asl2.0))))
 
-(define-public go-github-com-jacobsa-oglemock
-  (let ((commit "e94d794d06ffc6de42cb19d0dab3c219efdd6dcf")
-        (revision "0"))
-    (package
-      (name "go-github-com-jacobsa-oglemock")
-      (version (git-version "0.0.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/jacobsa/oglemock")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "14yxf8ykwdwkcccksl6741xgzcf8qykyi58kp4maxpgscqhdl8rq"))))
-      (build-system go-build-system)
-      (arguments
-       (list
-        #:import-path "github.com/jacobsa/oglemock"
-        ;; break loop with with go-github-com-jacobsa-ogletest
-        #:tests? #f))
-      (native-inputs (list
-                      go-github-com-jacobsa-oglematchers))
-      (home-page "https://github.com/jacobsa/oglemock")
-      (synopsis "Mocking framework for unit tests")
-      (description
-       "Package oglemock provides a mocking framework for unit tests.")
-      (license license:asl2.0))))
-
 (define-public go-github-com-jacobsa-ogletest
   (let ((commit "80d50a735a1108a2aeb7abc4a988d183f20c5292")
         (revision "0"))