summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-05 20:57:31 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 14:16:59 +0000
commit8b3daeca5545b97556b7f7f196bda6ca84e3dfa3 (patch)
treed681a2c55d2dd08d6280eb0b2999479282fcb306 /gnu/packages/golang.scm
parent1996575a7e30bc1c1bfd19840879f530869bec4e (diff)
downloadguix-8b3daeca5545b97556b7f7f196bda6ca84e3dfa3.tar.gz
gnu: go-golang-org-x-net: Move to golang-build.
* gnu/packages/golang.scm (go-golang-org-x-net,
go-golang-org-x-net-0.17, go-golang-org-x-net-html): Move from here ...
* gnu/packages/golang-build.scm: ... to here.

* gnu/packages/configuration-management.scm: Add (gnu packages golang-build) module.
* gnu/packages/education.scm: As above ...
* gnu/packages/file-systems.scm: As above ...
* gnu/packages/golang-check.scm: As above ...
* gnu/packages/golang-crypto.scm: As above ...
* gnu/packages/golang-web.scm: As above ...
* gnu/packages/golang-xyz.scm: As above ...
* gnu/packages/golang.scm: As above ...
* gnu/packages/ipfs.scm: As above ...
* gnu/packages/messaging.scm: As above ...
* gnu/packages/networking.scm: As above ...
* gnu/packages/uucp.scm: As above ...
* gnu/packages/version-control.scm: As above ...

Change-Id: If009e62555ada293f17cf0f42fde82c21ef4615e
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm60
1 files changed, 1 insertions, 59 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4e46c70d81..cd15d7debc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -81,6 +81,7 @@
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnupg)
+  #:use-module (gnu packages golang-build)
   #:use-module (gnu packages golang-check)
   #:use-module (gnu packages golang-crypto)
   #:use-module (gnu packages golang-web)
@@ -3651,65 +3652,6 @@ developed by the Go team.  It provides IDE features to any LSP-compatible
 editor.")
     (license license:bsd-3)))
 
-(define-public go-golang-org-x-net
-  (let ((commit "8e0e7d8d38f2b6d21d742845570dde2902d06a1d")
-        (revision "0"))
-    (package
-      (name "go-golang-org-x-net")
-      (version (git-version "0.5.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://go.googlesource.com/net")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "1fidlcn3vcz42v2lc0rpmqh3bz08bcklj6jvnmz2vvgc481ci5hy"))))
-      (build-system go-build-system)
-      (arguments
-       (list
-        #:import-path "golang.org/x/net"
-        ;; Source-only package
-        #:tests? #f
-        #:phases
-        #~(modify-phases %standard-phases
-            ;; Source-only package
-            (delete 'build))))
-      (synopsis "Go supplemental networking libraries")
-      (description "This package provides supplemental Go networking libraries.")
-      (home-page "https://go.googlesource.com/net")
-      (license license:bsd-3))))
-
-(define-public go-golang-org-x-net-0.17
-  (let ((commit "b225e7ca6dde1ef5a5ae5ce922861bda011cfabd")
-        (revision "0"))
-    (package
-      (inherit go-golang-org-x-net)
-      (name "go-golang-org-x-net")
-      (version (git-version "0.17.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://go.googlesource.com/net")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "17zhim2m0r8nyy18g2lsawxm4rawix2qbjyn80x9vc6jc8fv05m9")))))))
-
-(define-public go-golang-org-x-net-html
-  (package
-    (inherit go-golang-org-x-net)
-    (name "go-golang.org-x-net-html")
-    (arguments
-     '(#:import-path "golang.org/x/net/html"
-       #:unpack-path "golang.org/x/net"))
-    (synopsis "HTML5-compliant tokenizer and parser")
-    (description
-     "This package provides an HTML5-compliant tokenizer and parser.")
-    (home-page "https://godoc.org/golang.org/x/net/html")))
-
 (define-public go-golang-org-x-image
   (let ((commit "58c23975cae11f062d4b3b0c143fe248faac195d")
         (revision "1"))