summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-04-23 14:27:30 +0200
committerLeo Famulari <leo@famulari.name>2023-04-23 11:04:16 -0400
commit9e903e9537e55c14799b84e0b81e92e32c8f70be (patch)
tree672b1ea6d3a84055502a75e9104d646f8f6cc4ea /gnu/packages/golang.scm
parent01544d32fb43a7dae0dfe531cc7a04b58c62a447 (diff)
downloadguix-9e903e9537e55c14799b84e0b81e92e32c8f70be.tar.gz
gnu: Add go-github-com-jcmturner-gofork.
* gnu/packages/golang.scm (go-github-com-jcmturner-gofork): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0adef25b2a..52bb95a573 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1458,6 +1458,29 @@ selection based on their relative weighting.  This package is useful for
 network applications that require accessing services using SRV records.")
     (license license:asl2.0)))
 
+(define-public go-github-com-jcmturner-gofork
+  (package
+    (name "go-github-com-jcmturner-gofork")
+    (version "1.7.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/jcmturner/gofork")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0w1j6b671121r6md5w7hnh2d0sa332pw5q49yihw23wdfinknyin"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/jcmturner/gofork"))
+    (home-page "https://github.com/jcmturner/gofork")
+    (synopsis "Modified Go standard library packages")
+    (description
+     "This repository contains modified Go standard library packages for use as work
+arounds until issues are addressed in the official distribution.")
+    (license license:bsd-3)))
+
 (define-public go-github-com-kataras-golog
   (package
     (name "go-github-com-kataras-golog")