summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorAdam Kandur <kefironpremise@gmail.com>2022-09-05 16:34:34 +0300
committerChristopher Baines <mail@cbaines.net>2022-09-10 11:32:47 +0100
commita53ef49baa6256a29dabb86c5d36f850f3838e2a (patch)
tree5bbdbb348ea892c98358da56cad42091e3712da5 /gnu/packages/golang.scm
parentb8850bf2c1e5d13ca4ea16eae315c1e1c2e01af6 (diff)
downloadguix-a53ef49baa6256a29dabb86c5d36f850f3838e2a.tar.gz
gnu: Add go-github-com-goccy-go-json.
* gnu/packages/golang.scm (go-github-com-goccy-go-json): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 610e18310d..29a11a4ec1 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2923,6 +2923,28 @@ loading algorithms.")
 is similar to Go's standard library @code{json} and @code{xml} package.")
     (license license:expat)))
 
+(define-public go-github-com-goccy-go-json
+  (package
+    (name "go-github-com-goccy-go-json")
+    (version "0.9.10")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/goccy/go-json")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1bg8p4c6r8r0kixdxv2m8xmdsmb1zl5sd8czswpccldjk3c358wp"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/goccy/go-json"))
+    (home-page "https://github.com/goccy/go-json")
+    (synopsis "JSON encoder/decoder in Go")
+    (description
+     "Fast JSON encoder/decoder compatible with encoding/json for Go.")
+    (license license:expat)))
+
 (define-public go-github-com-getsentry-raven-go
   (let ((commit "5c24d5110e0e198d9ae16f1f3465366085001d92")
         (revision "0"))