summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:32 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:23 -0500
commitba8babd9e74ab5692cfccc32f7dbafe9506a5002 (patch)
tree0d931e94de13fff754acdf95ce7d3a7441896d57 /gnu/packages/golang.scm
parentd0f3a60169ebb2505653afd588aea33ab02e8ca5 (diff)
downloadguix-ba8babd9e74ab5692cfccc32f7dbafe9506a5002.tar.gz
gnu: go-github-com-nwidger-jsoncolor: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-nwidger-jsoncolor): Move from
here...
* gnu/packages/golang-web.scm: ...to here.

Change-Id: I924581a553c7b59b1be3e274a1845af68b438bcb
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 0 insertions, 27 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index bcc10946b1..9fbe2d5b97 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9049,33 +9049,6 @@ style your output, without you having to deal with all kinds of weird ANSI
 escape sequences and color conversions.")
     (license license:expat)))
 
-(define-public go-github-com-nwidger-jsoncolor
-  (package
-    (name "go-github-com-nwidger-jsoncolor")
-    (version "0.3.0")
-    (home-page "https://github.com/nwidger/jsoncolor")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url home-page)
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "13rd146pnj7qm70r1333gyd1f61x40nafxlpvdxlci9h7mx8c5p8"))))
-    (build-system go-build-system)
-    (arguments
-     `(#:import-path "github.com/nwidger/jsoncolor"))
-    (native-inputs
-     (list go-github-com-fatih-color))
-    (synopsis "Colorized JSON marshalling and encoding")
-    (description
-     "@code{jsoncolor} is a drop-in replacement for @code{encoding/json}'s
-@code{Marshal} and @code{MarshalIndent} functions and @code{Encoder} type
-which produce colorized output using github.com/fatih/color.")
-    (license license:expat)))
-
 (define-public go-github-com-olekukonko-tablewriter
   (package
     (name "go-github-com-olekukonko-tablewriter")