summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 11:05:17 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:23 +0300
commitc99318761c1ca2afcb19c644c830b7952e2688e9 (patch)
tree80544bd29da6d8ec2b10d88c7432094a93cfed7c /gnu/packages/golang.scm
parentb3cd7c9bff94d35a41847f3a8660f7290b9f5318 (diff)
downloadguix-c99318761c1ca2afcb19c644c830b7952e2688e9.tar.gz
gnu: Add go-github-com-go-git-go-billy.
* gnu/packages/golang.scm (go-github-com-go-git-go-billy): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9d99aea339..9bd4f8fc50 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5136,3 +5136,29 @@ errors (warnings).")
     (synopsis "Gcfg reads INI-style configuration files into Go structs")
     (description "Gcfg reads INI-style configuration files into Go structs.")
     (license license:bsd-3)))
+
+(define-public go-github-com-go-git-go-billy
+  (package
+    (name "go-github-com-go-git-go-billy")
+    (version "5.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/go-git/go-billy")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1wdzczfk1n50dl2zpgf46m69b0sm8qkan5xyv82pk9x53zm1dmdx"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/go-git/go-billy/v5"))
+    (native-inputs
+     `(("go-gopkg-in-check-v1" ,go-gopkg-in-check-v1)))
+    (home-page "https://github.com/go-git/go-billy/")
+    (synopsis "Filesystem abstraction for Go")
+    (description "Billy implements an interface based on the os standard
+library, allowing to develop applications without dependency on the underlying
+storage.  Makes it virtually free to implement mocks and testing over
+filesystem operations.")
+    (license license:asl2.0)))