summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2023-06-22 19:54:25 +0900
committerLudovic Courtès <ludo@gnu.org>2023-10-12 18:53:06 +0200
commitcf111ec0bae4bd0a48fa737de1d0bc5ed4d15da2 (patch)
tree34e29a5e66a96c7f562c02ca360bef0ed63017bd /gnu/packages/golang.scm
parent26a31e63d343e188c8813e7fb2d359762815792d (diff)
downloadguix-cf111ec0bae4bd0a48fa737de1d0bc5ed4d15da2.tar.gz
gnu: Add go-github-com-delthas-go-libnp.
gnu/packages/golang.scm (go-github-com-delthas-go-libnp): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f95ecec75d..251eba438a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10634,6 +10634,30 @@ RFC-5802 and RFC-7677.")
 bindings for the D-Bus message bus system.")
     (license license:bsd-2)))
 
+(define-public go-github-com-delthas-go-libnp
+  (let ((commit "0e45ece1f878f202fee2c74801e287804668f677"))
+    (package
+      (name "go-github-com-delthas-go-libnp")
+      (version (git-version "0.0.0" "0" commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/delthas/go-libnp")
+                       (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                  (base32
+                    "1hylpvwz3kb8wr00knba6mggjacak2vmqafwysansj0ns038lp8w"))))
+      (build-system go-build-system)
+      (arguments `(#:import-path "github.com/delthas/go-libnp"))
+      (propagated-inputs (list go-github-com-godbus-dbus))
+      (home-page "https://github.com/delthas/go-libnp")
+      (synopsis "Tiny library providing information about now-playing media")
+      (description "@code{go-libnp} is a tiny cross-platform library for
+extracting information about the music/image/video that is Now Playing on the
+system.")
+      (license license:expat))))
+
 (define-public go-github-com-prometheus-common
   (package
     (name "go-github-com-prometheus-common")