summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:03 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:18 -0500
commitd0dc31a56ec497e070eb6662c8ff6b4b3e5c7cef (patch)
treeb8722172a680f51c3128ce2d3de17c2e5c084b96 /gnu/packages/golang.scm
parent032cac46ed01ceb628a08bdbcc97b256a71002ab (diff)
downloadguix-d0dc31a56ec497e070eb6662c8ff6b4b3e5c7cef.tar.gz
gnu: go-github-com-microcosm-cc-bluemonday: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-microcosm-cc-bluemonday): Move from
here...
* gnu/packages/golang-web.scm: ...to here.

Change-Id: Ie5122f8afb2a29574c0e0bb5eb96665ecb77176b
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 52d65d4967..292d4f799d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9165,30 +9165,6 @@ converts it into syntax highlighted HTML, ANSI-coloured text, etc.")
 transforms one JSON document into another through a JMESPath expression.")
     (license license:asl2.0)))
 
-(define-public go-github-com-microcosm-cc-bluemonday
-  (package
-    (name "go-github-com-microcosm-cc-bluemonday")
-    (version "1.0.3")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/microcosm-cc/bluemonday")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "071ph097c1iwbcc33x6kblj9rxb1r4mp3qfkrj4qw5mg7qcqxydk"))))
-    (build-system go-build-system)
-    (arguments
-     `(#:import-path "github.com/microcosm-cc/bluemonday"))
-    (propagated-inputs
-     (list go-github-com-chris-ramon-douceur
-           go-golang-org-x-net))
-    (home-page "https://github.com/microcosm-cc/bluemonday/")
-    (synopsis "HTML sanitizer")
-    (description "@code{bluemonday} is a HTML sanitizer implemented in Go.")
-    (license license:bsd-3)))
-
 (define-public go-github-com-muesli-reflow-wordwrap
   (package
     (name "go-github-com-muesli-reflow-wordwrap")