summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-19 21:22:21 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 09:37:35 +0100
commitd2d5a3af3ec70757728dc379970f5cdda8bc366c (patch)
treeee9538e1082c89128d0ec045c7a5e61cb7fe6912 /gnu/packages/golang.scm
parent12c72ab2cccf2619de2ebbd18129d069af75d941 (diff)
downloadguix-d2d5a3af3ec70757728dc379970f5cdda8bc366c.tar.gz
gnu: go-github-com-golang-protobuf-proto: Adjust package name.
Rename go-github-com-golang-protobuf-proto to the Golang module name as
seen in go.mod. Due to lack of support of building submodules in
go-build-system 'build phase is omitted and 'check phase is substituted by
custom one providing nested path tests.

* gnu/packages/golang.scm (go-github-com-golang-protobuf-proto): Rename to...
(go-github-com-golang-protobuf): ... this.
<#:unpack-path>: Remove argument.
<#:phases>: Delete 'build phase. Add custom 'check phase and run tests
for all submodules.
(go-github-com-prometheus-common,
go-github-com-matttproud-golang-protobuf-extensions-pbutil)
[propagated-inputs]: Adjust accordingly.

* gnu/packages/golang-check.scm (go-github-com-onsi-gomega)
[propagated-inputs]: Likewise

* gnu/packages/golang-web.scm (go-github-com-golang-groupcache,
go-github-com-quic-go-quic-go)
[propagated-inputs]: Likewise

* gnu/packages/golang-xyz.scm (go-github-com-prometheus-client-model)
[propagated-inputs]: Likewise

* gnu/packages/syncthing.scm (go-github-com-matttproud-golang-protobuf-extensions-pbutil)
[propagated-inputs]: Likewise

Change-Id: I28c11739247a5ebafefd032d04a548a683fa0454
Co-authored-by: Hilton Chain <hako@ultrarare.space>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 17 insertions, 8 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e453a51fb2..6f267cbd0c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6229,23 +6229,32 @@ test results.")
     (home-page "https://github.com/gotestyourself/gotestsum")
     (license license:asl2.0)))
 
-(define-public go-github-com-golang-protobuf-proto
+(define-public go-github-com-golang-protobuf
   (package
-    (name "go-github-com-golang-protobuf-proto")
+    (name "go-github-com-golang-protobuf")
     (version "1.5.3")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                     (url "https://github.com/golang/protobuf")
-                     (commit (string-append "v" version))))
+                    (url "https://github.com/golang/protobuf")
+                    (commit (string-append "v" version))))
               (file-name (git-file-name name version))
               (sha256
                (base32
                 "03f1w2cd4s8a3xhl61x7yjx81kbzlrjpvnnwmbhqnz814yi7h43i"))))
     (build-system go-build-system)
     (arguments
-     '(#:import-path "github.com/golang/protobuf/proto"
-       #:unpack-path "github.com/golang/protobuf"))
+     (list #:import-path "github.com/golang/protobuf"
+           #:phases
+           #~(modify-phases %standard-phases
+               ;; XXX: Workaround for go-build-system's lack of Go modules
+               ;; support.
+               (delete 'build)
+               (replace 'check
+                 (lambda* (#:key tests? import-path #:allow-other-keys)
+                   (when tests?
+                     (with-directory-excursion (string-append "src/" import-path)
+                       (invoke "go" "test" "-v" "./..."))))))))
     (propagated-inputs
      (list go-google-golang-org-protobuf))
     (synopsis "Go support for Protocol Buffers")
@@ -7589,7 +7598,7 @@ formatting information, rather than the current locale name.")
          ;; Source-only package
          (delete 'build))))
     (propagated-inputs
-     (list go-github-com-golang-protobuf-proto
+     (list go-github-com-golang-protobuf
            go-github-com-matttproud-golang-protobuf-extensions-pbutil
            go-github-com-prometheus-client-model))
     (synopsis "Prometheus metrics")
@@ -7647,7 +7656,7 @@ system, kernel, and process metrics from the @file{/proc} pseudo file system.")
          (delete 'build))))
     (propagated-inputs
      (list go-github-com-beorn7-perks-quantile
-           go-github-com-golang-protobuf-proto
+           go-github-com-golang-protobuf
            go-github-com-prometheus-client-model
            go-github-com-prometheus-common
            go-github-com-prometheus-procfs