summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 23:18:18 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:04 +0000
commite946e341df663fddbbaf3d9fbccb3e26eda66cff (patch)
treefd3a490fda464d875b7ed774dbbfc6241cfcc811 /gnu/packages/golang.scm
parentea9204ab4ba02136cd70336a3a6c4253dd89b418 (diff)
downloadguix-e946e341df663fddbbaf3d9fbccb3e26eda66cff.tar.gz
gnu: go-github-com-marten-seemann-qtls: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-marten-seemann-qtls): Move from
here ...
* gnu/packages/golang-crypto.scm: ... to here.

Change-Id: I036e80323ac61d91743e2c42f878ecad06e6c9b9
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3ef5eecb62..45aadbeb39 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7064,32 +7064,6 @@ All locks are implemented with read-write mutexes.  To use them like a regular
 mutex, simply ignore the RLock/RUnlock functions.")
       (license license:unlicense))))
 
-(define-public go-github-com-marten-seemann-qtls
-  (package
-    (name "go-github-com-marten-seemann-qtls")
-    (version "0.4.1")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                     (url "https://github.com/marten-seemann/qtls")
-                     (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "0dz60y98nm7l70hamq0v2vrs2dspyr5yqhnrds2dfh7hchxvq76j"))))
-    (build-system go-build-system)
-    (arguments
-     '(#:import-path "github.com/marten-seemann/qtls"
-       ;; The test suite requires networking.
-       #:tests? #f))
-    (propagated-inputs
-     (list go-golang-org-x-crypto))
-    (synopsis "TLS 1.3 with QUIC in Go")
-    (description "This package provides @code{qtls}, a QUIC-capable variant of
-the Go standard library's TLS 1.3 implementation.")
-    (home-page "https://github.com/marten-seemann/qtls")
-    (license license:bsd-3)))
-
 (define-public go-github-com-cheekybits-genny
   (package
     (name "go-github-com-cheekybits-genny")