summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-07 21:28:03 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 14:26:07 +0000
commitf9ead8f7a832eb0b02b78de5ff379bfa0a1fc310 (patch)
tree109f22add3adf69a5b4d4288a57de923640d0513 /gnu/packages/golang.scm
parentb5bbfef22a51006945835dabb187ec400429128c (diff)
downloadguix-f9ead8f7a832eb0b02b78de5ff379bfa0a1fc310.tar.gz
gnu: go-github-com-burntsushi-toml: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-burntsushi-toml): Move
from here ...
* gnu/packages/golang-xyz.scm: ... to here.

* gnu/packages/golang-check.scm: Add (gnu packages golang-xyz) module.
* gnu/packages/golang.scm: As above.
* gnu/packages/shellutils.scm: As above.

Change-Id: If8a645431a1fb17159681daae70db49fd21b37c1
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 0 insertions, 23 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 269bfdec95..5a2972427c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3808,29 +3808,6 @@ The specific case of loading packages should still be done by invoking the
 loading algorithms.")
       (license license:bsd-3))))
 
-(define-public go-github-com-burntsushi-toml
-  (package
-    (name "go-github-com-burntsushi-toml")
-    (version "1.2.1")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/BurntSushi/toml")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1v9czq4hsyvdz7yx70y6sgq77wmrgfmn09r9cj4w85z38jqnamv7"))))
-    (build-system go-build-system)
-    (arguments
-     '(#:import-path "github.com/BurntSushi/toml"))
-    (home-page "https://github.com/BurntSushi/toml")
-    (synopsis "Toml parser and encoder for Go")
-    (description
-     "This package is toml parser and encoder for Go.  The interface
-is similar to Go's standard library @code{json} and @code{xml} package.")
-    (license license:expat)))
-
 (define-public go-github-com-hashicorp-go-uuid
   (package
     (name "go-github-com-hashicorp-go-uuid")