summary refs log tree commit diff
path: root/gnu/packages/gps.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-12-27 23:54:23 +0100
committerLudovic Courtès <ludo@gnu.org>2014-12-27 23:54:23 +0100
commit2a8d44015ff2672b7a9a2ea5054b51a83b0e934b (patch)
tree00cdf5dac6acd2bd736a726bc5e032f328d29d6a /gnu/packages/gps.scm
parentcc9a5c1454f49850c078045c88a300c1195eabc8 (diff)
downloadguix-2a8d44015ff2672b7a9a2ea5054b51a83b0e934b.tar.gz
gnu: libxml2: Add search path specification.
* gnu/packages/xml.scm (libxml2)[native-search-paths, search-paths]: New
  fields.
* gnu/packages/gnome.scm (gnome-doc-utils)[arguments]: Remove.
* gnu/packages/gps.scm (gpscorrelate)[arguments]: Remove settings for
  'XML_CATALOG_FILES' from 'configure' phase.
* gnu/packages/web.scm (tinyproxy)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages/gps.scm')
-rw-r--r--gnu/packages/gps.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index 1fbf38f125..231b1d1b04 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -100,17 +100,7 @@ manipulate maps.")
                      (substitute* "Makefile"
                        (("prefix[[:blank:]]*=.*$")
                         (string-append "prefix = " (assoc-ref outputs "out")
-                                       "\n")))
-
-                     ;; Make sure the DocBook XML and XSL files are found.
-                     ;; Note: this is a space-separated list.
-                     (setenv "XML_CATALOG_FILES"
-                             (string-append (assoc-ref inputs "docbook-xml")
-                                            "/xml/dtd/docbook/catalog.xml "
-                                            (assoc-ref inputs "docbook-xsl")
-                                            "/xml/xsl/"
-                                            ,(package-full-name docbook-xsl)
-                                            "/catalog.xml")))
+                                       "\n"))))
                    %standard-phases)
          #:tests? #f))
       (inputs