summary refs log tree commit diff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-04-25 03:26:05 +0000
committerLeo Famulari <leo@famulari.name>2021-04-25 14:49:57 -0400
commit76fb1a5cf29c3ecf189776eb16db4fcb89bb1939 (patch)
treecd9a0cd691cd286d3ee8c77cbdeb2246b2d825a2 /gnu/packages/graph.scm
parent0b5ab41f29011db79babf8163e97e300c5dfcc69 (diff)
downloadguix-76fb1a5cf29c3ecf189776eb16db4fcb89bb1939.tar.gz
gnu: Add python-louvain 0.15.
* gnu/packages/graph.scm (python-louvain): Rename variable to
python-louvain-0.6.
(python-louvain): New variable.
* gnu/packages/bioinformatics.scm (python-scanpy)[propagated-inputs]: Use
python-louvain-0.6.

Co-authored-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index d2e4c875a1..95506c69a9 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -6,6 +6,7 @@
 ;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2020 Alexander Krotov <krotov@iitp.ru>
 ;;; Copyright © 2020 Pierre Langlois <pierre.langlos@gmx.com>
+;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -231,6 +232,27 @@ subplots, multiple-axes, polar charts, and bubble charts. ")
 (define-public python-louvain
   (package
     (name "python-louvain")
+    (version "0.15")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "python-louvain" version))
+       (sha256
+        (base32 "1sqp97fwh4asx0jr72x8hil8z8fcg2xq92jklmh2m599pvgnx19a"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-networkx" ,python-networkx)
+       ("python-numpy" ,python-numpy)))
+    (home-page "https://github.com/taynaud/python-louvain")
+    (synopsis "Louvain algorithm for community detection")
+    (description
+     "This package provides a pure Python implementation of the Louvain
+algorithm for community detection in large networks.")
+    (license license:bsd-3)))
+
+(define-public python-louvain-0.6
+  (package
+    (name "python-louvain")
     (version "0.6.1")
     ;; The tarball on Pypi does not include the tests.
     (source (origin