summary refs log tree commit diff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorTomáš Čech <sleep_walker@gnu.org>2015-03-17 16:32:03 +0100
committerTomáš Čech <sleep_walker@gnu.org>2015-03-17 16:32:03 +0100
commita0db8b4dcc8206f45cb80791817cf59f93b2e6a9 (patch)
tree171af139c0ba295dd9ef2e6928aba93056836b64 /gnu/packages/graphics.scm
parent004eb31859971f9602f618cbdf6612f4bcaddd9c (diff)
downloadguix-a0db8b4dcc8206f45cb80791817cf59f93b2e6a9.tar.gz
gnu: agg: reverting commit d2c89faa8876dbcafcd213a0050f286377cec056
commit was still missing gnu-system.am sections and added patches
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm55
1 files changed, 1 insertions, 54 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index c6ccc34a58..1ee4d7e177 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -23,16 +23,10 @@
   #:use-module (guix build-system cmake)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages)
-  #:use-module (gnu packages bash)
   #:use-module (gnu packages pkg-config)
-  #:use-module (gnu packages autotools)
   #:use-module (gnu packages compression)
-  #:use-module (gnu packages fontutils)
   #:use-module (gnu packages multiprecision)
-  #:use-module (gnu packages boost)
-  #:use-module (gnu packages xorg)
-  #:use-module (gnu packages sdl)
-)
+  #:use-module (gnu packages boost))
 
 (define-public cgal
   (package
@@ -158,50 +152,3 @@ output.")
     ;; The web site says it's under a BSD-3 license, but the 'LICENSE' file
     ;; and headers use different wording.
     (license (license:non-copyleft "file://LICENSE"))))
-
-(define-public agg
-  (package
-    (name "agg")
-    (version "2.5")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "http://www.antigrain.com/agg-"
-                                  version ".tar.gz"))
-              (sha256
-               (base32 "07wii4i824vy9qsvjsgqxppgqmfdxq0xa87i5yk53fijriadq7mb"))
-              (patches (list (search-patch "am_c_prototype.patch")
-                             (search-patch
-                              "antigrain-geometry-no_rpath.patch")))))
-    (build-system gnu-build-system)
-    (arguments
-     '(#:configure-flags
-       (list (string-append "--x-includes=" (assoc-ref %build-inputs "libx11")
-                            "/include")
-             (string-append "--x-libraries=" (assoc-ref %build-inputs "libx11")
-                            "/lib"))
-       #:phases
-       (alist-cons-after
-        'unpack 'autoreconf
-        (lambda _
-          ;; let's call configure from configure phase and not now
-          (substitute* "autogen.sh" (("./configure") "# ./configure"))
-          (zero? (system* "sh" "autogen.sh")))
-        %standard-phases)))
-    (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("libtool" ,libtool)
-       ("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("bash" ,bash)))
-    (inputs
-     `(("libx11" ,libx11)
-       ("freetype" ,freetype)
-       ("sdl" ,sdl)))
-
-    (home-page "http://antigrain.com")
-    (synopsis "High-quality 2D graphics rendering engine for C++")
-    (description
-     "Anti-Grain Geometry is a high quality rendering engine written in C++.
-It supports sub-pixel resolutions and anti-aliasing.  It is also library for
-rendering SVG graphics.")
-    (license license:gpl2+)))